1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 disabling ajax

Discussion in 'XenForo Questions and Support' started by localhost8080, Aug 1, 2013.

  1. localhost8080

    localhost8080 Well-Known Member

    Hello there,

    is there any possibility to disable ajax on xenforum?

    Thanks.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I am not aware of a global switch. But there is this option:

    Admin CP -> Appearance -> Style Properties -> Overlays and Tooltips -> Enable Overlays

    Overlays are AJAX, but that's not all of the AJAX.
     
  3. alkahf

    alkahf Member

    Hello
    I have small problem with Ajax!
    In message template I made two tables:
    • first table displays when browsers width > 600 pixels
    • second table displays when browsers width < 600 pixels
    Every thing working good but small problem happen when submit reply or edit post message: then displaying both tables!
    But when i refresh page then display one table only.
    So i need to disable Ajax (Or reload page) when submit reply or submit (Save changes) when edit message!​
    is there any way ?

    thank you
     
    Last edited: Oct 10, 2013
  4. alkahf

    alkahf Member

    Okey!
    When i disabled [Enable Overlays] then no problem when edit message or delete!
    So my problem now when submit [post reply] only!
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  6. alkahf

    alkahf Member

    Thank you Jake for your help but it is not working for me!
    i made two changes in: thread_reply_new_posts and message
    and one change in: /library/XenForo/ViewPublic/Thread/ViewPosts.php
    Then 2 tables are hidden and thread is blank!
     
  7. alkahf

    alkahf Member

    I need in form post_edit and form quick_reply some thing like that:
    data-ajax="false"
     

Share This Page