1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Deleting RSS Feeds still leaves LOGS behind

Discussion in 'General XenForo Discussion and Feedback' started by mrGTB, Nov 11, 2011.

  1. mrGTB

    mrGTB Well-Known Member

    I few times now I've deleted some RSS Feeds while testing things and then when trying to run the RSS importer manually to re-import them back, they don't get imported. vBulletin used to be like this, I checked the database using phpMyAdmin and spotted that logs are still left behind for them, even though they've been deleted from the forums. Hence why they don't get re-imported back because they show as still being there in database RSS Feed logs.

    I'm not sure if this is intended or not, but letting you know that you have to manually delete all logs from the database also before you can re-import them back.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You need to also delete the threads.
    That will then remove the entries from the xf_feed_log table.

    Otherwise you would end up with duplicate content.
  3. mrGTB

    mrGTB Well-Known Member

    That's what I do - turn feed off, then delete threads first. Then sometimes (not all the time), when I go into the database and check there are still logs listed even though all those threads have been permanently deleted.

    Obviously, I'm going to try and re-import RSS Feeds if the threads are still present there for them.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I didn't experience that with my testing.

    Every single entry in the table was deleted once the threads and feeds were.
  5. mrGTB

    mrGTB Well-Known Member

    Well, lets just say I've done this now over 15 times. So it's not a one off.

    For example; when I was importing the DVD Movie releases, setting up how they get presented in threads. When deleting them because I needed to make some change with the feed itself, then running the feed again manually 2-3 minutes later they don't get imported back again. I had to keep going into database deleting the logs and only then will it import them back manually.

Share This Page