• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Deleted 3 posts but...

ineedhelp

Well-known member
#1
I deleted 3 posts in a thread, including the opening post and the entire thread got deleted.

When I go to the thread URL it says "The requested thread could not be found"

But the Forum Statistics, "Message" stats haven't gone down and the thread had around 17,000 posts in it.

Help needed - Thanks.
 

Brogan

XenForo moderator
Staff member
#2
If you delete the first post in a thread it deletes the thread.

The overlay states that quite clearly.

Note: This is the first post in the thread. Deleting it will delete the whole thread.

The forum stat's are updated via cron periodically.
 

ineedhelp

Well-known member
#3
If you delete the first post in a thread it deletes the thread.

The overlay states that quite clearly.

Note: This is the first post in the thread. Deleting it will delete the whole thread.

The forum stat's are updated via cron periodically.
The overlay said "deleting 3 posts" something like that…. I know it can delete the thread but that didn't cross my mind…. Because prior to deleting those posts…. I 'moved' a few mosts from another thread which also included the opening post. That worked fine…. So I thought, if I delete the opening post, it'll just make the next users post as the opening post.

Forum stats are updated every 15 minutes and now it's been around 30 minutes. Stats are increasing as normal.
 

ineedhelp

Well-known member
#5
I've deleted two other threads just for testing… 1 with 90 posts and other other with 84 posts…. "Message" stats updated perfectly fine.

But the thread I deleted with around 17,000 posts still isn't showing a decline in the "Message" stats

What could be the reason?
 

ineedhelp

Well-known member
#8
I've looked everywhere, it's gone…. There must be a bug somewhere in the system, xenforo?

Maybe because of the oldest post dating back 2011 and or having thousands of post… The thread got deleted, but the stats are not reflecting the difference, due to a unknown bug?
 

ineedhelp

Well-known member
#9
Really odd, but only now has the Message stats updated correctly. Maybe because the system had to deal with several thousands of posts, it took a few hours to complete. Hmm.

Looks like problem solved.