XF 1.3 delete all messages by a spammer

drastic

Well-known member
had a spammer get through and blast 500 messages on my forum today.

how can i delete them and ALL their messages in the fastest way possible?
 

drastic

Well-known member
i'm logged in as an admin, but when i click on his profile card, there's no spam management options.

i've pressed YES on every option for the admin group.

also have most things enabled in the spam management options screen.

this doesn't show up for me...

 

Brogan

XenForo moderator
Staff member
As it explains on the help page, you may need to change the criteria in the ACP.

It's also a moderator function, not administrator.
 

drastic

Well-known member
not sure what criteria to change.

logged in as admin, all permissions in admin group are set to "allow" .

spam management options are pretty much set at default or all yes.

i cleared caches to see if that helped.

i still get this...

hatespammers.jpg
 

drastic

Well-known member
oh man...ok...that explains it. i need to add myself as a moderator/admin - not just admin.

trying now. thanks.
 

Brogan

XenForo moderator
Staff member
You said the member has posted 500 messages.
You will need to increase the threshold to above that.

upload_2014-3-23_21-55-33.png
 

drastic

Well-known member
no luck.

added myself as super moderator, enabled all permissions. created a new user, added as moderator, all permissions a go - no luck.

for some reason, i can't get the spam control options to appear.
 

drastic

Well-known member
figured that, but i can't figure out where.

i created two super moderators, with all permissions enabled...can't get the spam tool to appear.
 

drastic

Well-known member
analyzed.jpg

I also added myself as a super moderator to the forum in the node tree.

can't crack this can spam cleaner open!
 

drastic

Well-known member
i tried to ensure literally everything is set to yes/allow for the admin, then added it as a super moderator too.

i'm not exactly sure where else to look.
 

drastic

Well-known member
oh. my. bad word here. god.

i had a digit set to 0 and my font is so small that i didn't see the message regarding limits set to zero will not show the spam option.

thanks a TON for helping me.

Appreciate it.
 
Last edited:
Top