XF 1.4 Database tables getting deleted after converted from SMF

bcercan

Active member
#1
After converting from SMF, XenForo deleting some tables in random times with the following error:

Code:
An unexpected database error occurred. Please try again later.
<!-- Mysqli prepare error: Table 'kkforum_xf.xf_phrase_compiled' doesn't exist -->
When I checked database it shows 160 tables while it was 166 before which means XenForo get deleted 6 tables. I'm manually importing tables again but it keeps deleting them after 24 hours.

And I'm pretty sure thats not about my hosting provider. What am I supposed to do to fix this?
 

Jeremy

Well-known member
#2
XenForo will not remove tables. Do you have add-on add-ons installed? Custom cron jobs? Have you done anything else to your system post conversion?
 

Brogan

XenForo moderator
Staff member
#4
What do you mean by "everything is done"?

As Jeremy has stated, table shouldn't be deleted so you may want to contact your host to determine why.
 

bcercan

Active member
#5
I reinstalled from the beginning and still getting this error. I believe there is no problem with my host.

XenForo changing the database structure sometimes, I don't know why and how.

 

Mike

XenForo developer
Staff member
#6
There is no reason for XF to really be touching the table structure. This is almost certainly pointing to an issue with the host. A hardware problem or the disk being full are the two most likely causes.
 

Brogan

XenForo moderator
Staff member
#7
What is your relation to the other user who is also posting about this same error with the same site?

I have already responded to the ticket raised by the license holder about this.
 

bcercan

Active member
#8
What is your relation to the other user who is also posting about this same error with the same site?

I have already responded to the ticket raised by the license holder about this.
I was trying to help him but I didnt know he already ticket about it. So you can delete the thread. Thanks!
 
Top