XF 1.4 Database error

SimplyTitan

Member
For a few weeks now we have not been able to access our forum so I contacted host to see if they could fix it but still nothing so I'm trying here. When I load the site I get this error. "An unexpected database error occurred. Please try again later." Could anyone help me with this. It was fine one day then the next just that.

Thank you
 

Tracy Perry

Well-known member
For a few weeks now we have not been able to access our forum so I contacted host to see if they could fix it but still nothing so I'm trying here. When I load the site I get this error. "An unexpected database error occurred. Please try again later." Could anyone help me with this. It was fine one day then the next just that.

Thank you
View the page source and see if it gives an error.
 

Brogan

XenForo moderator
Staff member
It looks to be an issue with the database credentials in the config.php file.

The actual error is '<!-- Access denied for user '<redacted>'@'localhost' to database '<redacted>' -->'.

If you have not personally changed anything, contact your host and ask them to investigate.
 

SimplyTitan

Member
It looks to be an issue with the database credentials in the config.php file.

The actual error is '<!-- Access denied for user '<redacted>'@'localhost' to database '<redacted>' -->'.

If you have not personally changed anything, contact your host and ask them to investigate.
Thank you. I will look into this and contact the host if nothing works. Also yes nothing has been touched on the forum for over a year other then it being active.
 
Top