1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom Avatars not showing

Discussion in 'Troubleshooting and Problems' started by Zmolahah, May 5, 2013.

  1. Zmolahah

    Zmolahah Member

    So I recently noticed custom avatars on my website stopped working. I don't think it's an issue with my skin because it was working for the skin before and I reinstalled the skin and it still is not showing up for me I also reinstalled Xenforo and the avatars are still not showing up however default avatars still work? Anyone know the problem? My website is veraid.net. Thanks (You can also use zmolahah.com)
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Check the permissions on your /data directory in your forum root. Make sure it is 777 and the directories/files below it are also 777.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

  4. Zmolahah

    Zmolahah Member

    Sorry but where can I find the files to put as 777? Admin CP or Public HTML? And where in the Admin CP or Public? Thanks for the support

    [Edit]
    Found the data folder I'll try find what I need to change to 777

    [Edit]
    Just seeing loads of xml files. Sorry but I don't know what I'm supposed to edit?
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Depends on whether you use a VPS or shared hosting. If shared hosting, CPanel should have a file browser that will allow you to change permissions. Each host is different but it will be off the location you uploaded your forum files to. In my case it is under /var/www/twowheel, but under a shared hosting it is usually under your account name/public_html. If under a VPS, you can SSH into your VPS then go to the forum root and do a chmod 777 /data (I do this the hard way probably) and then do a cd /data then issue chmod 777 -R *.

    Also, I noticed that you said you reinstalled XenForo... that will DEFINITELY need to have the permissions changed since they do not default to the correct ones for /data and I believe /internal_data.
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    If you are seeing XML files only, then you are looking in the wrong place.
    This is what I have in my /var/www/twowheel/data directory
    example.png
     
  7. Zmolahah

    Zmolahah Member

    This is what I see in my Data folder
    [​IMG]
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    That is incorrect.

    You should only have:
    data.PNG

    You need to chmod -r 0777 for the data and internal data directories.
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

    Don' t know where those would have come from... unless you may have saved templates and they put them there. If you look at the very right you will see that your Avatars folder has a PERMS of 0755. That should be 0777. You should be able to highlight that item, select "Change Permissions" and it should have the ability to change permissions. You then will need to check all the folders/files under that directory to make sure that they are 0777 also.
     
  10. Zmolahah

    Zmolahah Member

    Changed everything to this
    [​IMG]
    Avatars are still not loading though. Will I have to wait or did I do something wrong?
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Did you also change the permissions on the files UNDER the /avatar folder. ALL files/directories under /data need to have 0777 permissions. Click on the avatars item and check the files under there also. I used CPanel only for a short time... does the "Change Permissions" option allow you do do it recursively. If so, go up one level and then highlight the /data folder and change permissions. Apply 0777 recursively.

    EDIT: Doesn't look like CPanel can do recursive... so you need to go into the AVATAR directory, highlight all files/folders in there and do a Change Permissions to them also. Each folder needs to be done as well as all files under them for everything in the /data and the /internal_data directories.
     
  12. Zmolahah

    Zmolahah Member

    Everything in data and internal data is now 0777 but it still does not show avatars for me
    [​IMG]
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    Apparently not.

    example.png
    The only thing I can suggest is that
    1] get with whomever set up your site before the install and have them use CPanel to fix the permissions
    2] let someone else access your CPanel and check out to make sure it is set correctly (this will require you giving them full access to your hosting account - you would then need to change your password after it was done).

    I would be happy to take a quick look at it... if you wish, just send me the logon information (your account username, password and your cpanel link) via a conversation. Be aware, Wheezy has just been released and I'm about to upgrade my OS from Squeeze - so shortly I will be a "little" busy.
     
  14. Zmolahah

    Zmolahah Member

    Sorry for the late reply but I sent the link to this thread to my web host. Lucky for me my web host offers amazing support and did it all for me (Arvixe.com is anyone is interested). They manually sorted it out for me and this was their reply

    Thanks for the support though I would have never been able to explain that issue to my host :)
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Who put that rule in .htaccess and why?
     
  16. Tracy Perry

    Tracy Perry Well-Known Member

    That would be an interesting question to have answered. There should not BE ANY .htaccess in that folder, so either the original poster created it and placed it there, the host service did or the OP used CPanel in some method to do it.
     

Share This Page