Fixed cURL error 28 issue with unfurl


Well-known member
Affected version
2.3 Beta 4
So, I have been getting a lot of these errors on 2.3 install. It's probably my server but I did some more tests.

On 2.2 Demo install offered here, I tried loading one of the problematic URLs. It tried unfurling it and gave up after a few seconds and showing the link as plain link. No error in backend.

On 2.3 at my end, it just keeps on showing the unfurling box and it just does not stop. And every time I load the post page, it creates another server error in the backend.

I posted the same link here on test node and it shows the same behavior. No matter how long I wait or refresh the page, the link keeps on loading box. I do not have access to backend here so not clear if it is generating server error log here as well. Things would be much easier to test out once 2.3 is available for demo installs!

Ideally, unfurl timeout errors should not be generating server error logs just like on 2.2 I think. And if the link refuses to unfurl in a few seconds, it should just appear as a regular like just like on 2.2.
It's an issue with that URL - it's not specific to 2.3.

Although the way the error is reported in the ACP likely needs finessing.
Top Bottom