1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CTA Login 1.0.1

Add Facebook, Twitter, and Google logins to the sidebar

  1. Brogan

    Brogan XenForo Moderator Staff Member

    Brogan submitted a new resource:

    CTA Login - Add Facebook, Twitter, and Google logins to the sidebar

    Read more about this resource...
     
  2. macara

    macara Active Member

  3. Brogan

    Brogan XenForo Moderator Staff Member

    You need to be running XenForo 1.3 and to configure the services in the ACP.
     
  4. macara

    macara Active Member

    Thank you for your interest.
    Now it is understandable.
     
  5. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    this ok but it doesnt show on one of my themes
    [​IMG]

    Code:
    <div class="sidebar">
    <div>
    <label id="SignupButton" for="LoginControl"><a class="inner" href="login/"><img data-cfsrc="styles/fusiongamer/xenforo/images/signupnow.png" src="http://portalcentric.net/forums/styles/fusiongamer/xenforo/images/signupnow.png"></a></label>
    </div>
    
    i cannot find the div class side bar any where i found the css for it but i cannot find that line of code i obtained using html editor any where not in page container no where

    best i get is this in side page container

    Code:
    <xen:if is="{$sidebar}"></div>
                    </div>
                  
                    <!-- sidebar -->
                    <aside>
                        <div class="sidebar">
                            <xen:hook name="page_container_sidebar">
                            <xen:include template="ad_sidebar_top" />
                            <xen:if is="!{$noVisitorPanel}"><xen:include template="sidebar_visitor_panel" /></xen:if>
                            {xen:raw $sidebar}
                            <xen:include template="ad_sidebar_bottom" />
                            </xen:hook>
                        </div>
                    </aside>
                </xen:if>
    i have spent hours looking for this and trying to place this modified code every where including extra.css file and it not working

    Code:
    <div class="section loginButton">
    <div class="secondaryContent">
    <div class="ctaLoginFacebook">
    <a class="fbLogin" href="register/facebook?reg=1"><span>Login with Facebook</span></a>
    </div>
     
  6. Russ

    Russ Well-Known Member

    You could try reverting the sidebar visitor panel template and using this again. I used an image for the sign up now and coded in the template directly.

    Next version of fusion gamer the image is gone it has no edits and uses a gradient there. Ironically we added this modification into our framework when 1.3 was releaded(our version), so these logins will be on the style your referring to unknown.
     
  7. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ?

    so these mods wont show till you guys release new version of fusion gamer?

    also i have designers on my site that modify the styles

    so i have the default fusion gamer theme and i import the modded version as a child node to the updated version does this mean the previous modded xml the 1 version below the new one will have the old template mods?

    New fusion gamer with latest mods -- > Old modded fusion gamer xml imported as child. <-- does the child get the new modded templates and keep the modded looks?, or i have to find the new moded templates from the new parent updated style and implement them into the old modded fusion gamer one?
     
  8. Russ

    Russ Well-Known Member

    Well that's best for another discussion and specifically when it gets released.

    However I just meant to get Brogans template mod to work, it's probably looking for the default login part in the sidebar panel, so for it to find it you'd need to revert your sidebar_visitor_panel for fusion gamer. Make a backup of it first of course. Or you may need to modify how it's finding the html.

    If you PM me a link with access I can help you debug it.
     
  9. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    is there a way i can have these mods now thx? well just the template mods and files?
    ok nm i fixed it i wonder y that happened.. but when i reverted it started working
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    It worked because you reverted the template to the original code.

    If the template has been edited and the section of code which the find and replace is carried out on is different, the template modification will fail.
     
  11. Mishal

    Mishal Member

    @Brogan

    When Try to use Twitter Button I got this message "An unexpected error occurred. Please try again later."
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    The code is the same as the core Twitter code from the login handle.

    So the error lies elswhere, not with this add-on.
     
  13. Mishal

    Mishal Member

    Its working now

    the error from twitter.
     
  14. Skylined

    Skylined Active Member

    @Brogan I'm missing the Google and Twitter icons. Am I missing somthing? :unsure:

    upload_2014-3-11_19-28-38.png


    I noticed that you forum is also missing Google's icon. Or is it just me? :unsure:
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Skylined likes this.
  16. Skylined

    Skylined Active Member

    Thanks, that was what I was missing. :)
     
  17. Rob

    Rob Well-Known Member

    I assume this is depreciated with the release of 1.3 final?
     
  18. Martok

    Martok Well-Known Member

    Not at all, this add-on is only compatible with Xenforo 1.3. It adds login buttons for Facebook, Twitter, and Google logins to the sidebar. Without the add-on, there aren't any social media login buttons there, only in the sign-up/login dropdown at the top of the forum.
     
    Brogan likes this.
  19. RO.

    RO. New Member

    I can't see any problems with this gents. The problem I'm having is with Facebook. It's a site I don't like so I don't really wanna open an acct just to get this log-in function. But when I go here:

    https://developers.facebook.com/docs/facebook-login

    ... I'm chasing my tail. There's no mention of forums and I cant see any functions to just generate the keys. Twitter make it pretty easy. Would anyone be able to direct me better please?
     
  20. Steve F

    Steve F Well-Known Member

Share This Page