• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Copying and pasting in a post causes the page to jump

Martok

Well-known member
#1
When typing a post and pasting in text, the page jumps upwards under certain circumstances.

Steps to reproduce:
  • Start a new thread
  • Scroll the page down so that the thread title box is off the top of the page (or even so the toolbar is off the top of the page)
  • Paste in some text
The page will jump upwards.

This also happens when replying in an existing thread using quick reply:
  • Scroll the page down so that the toolbar is off the top of the page
  • Paste in some text
The page will jump upwards.

I've done this on Chrome 28 on Windows 7.


Now you generally aren't going to scroll the page so that the toolbar is off the top. However, when writing long posts, this can happen and certainly it's likely that for a new thread that the thread title will be off the top of the page.
 

Brogan

XenForo moderator
Staff member
#2
I have experienced this myself many times, especially when posting resources, due to the narrrower editor.
 

Mike

XenForo developer
Staff member
#4
Seems to be Chrome specific (or at least doesn't happen in FF). I'm not sure what's triggering it yet...
 

Rudy

Well-known member
#6
Come to think of it, I've had that happen a couple of times. Using Chrome on desktop and Nexus 4 here, although it's rare I'll paste anything on the Nexus 4.
 
#8
There is a problem when using Samsung's default browser, when you try to post a reply even without pasting, as soon as you start typing it jumps to top of page - is it likely that this is the same issue?
 

Mike

XenForo developer
Staff member
#9
That's just a plain browser bug unfortunately - completely different issue. We have worked around it as best as possible. It doesn't happen in Chrome on Android (or iOS at all), for example.