Compiling FFmpeg From Source

Compiling FFmpeg From Source

Chris D

XenForo developer
Staff member
I think newer versions might have removed the libvoaac encoder.

Remove the last line and remove the back slash from the libx264 line.
 

rootsxrocks

Active member
I think newer versions might have removed the libvoaac encoder.

Remove the last line and remove the back slash from the libx264 line.
Could you edit that out of the instructions or make an updated set, I just spent a lot of time trying to make that work thinking I was doing something wrong, as the page before i came to this post. the comments on the previous page implied it was necessary. I did learn a few things while trying to shove it in but I just wanna put a webm on my site and have spent 5 hours trying to install the required ffmpeg

and now I'm getting ERROR: libtheora libvorbis and libass not found What do i need for media gallery in 2019 ?
 

rootsxrocks

Active member
Ahh man, I don't take the easy road most of the time;) I don't learn anything that way.
I think I about have it using the guide here https://trac.ffmpeg.org/wiki/CompilationGuide/Centos
I probably have more installed than i need , but it went much smoother after I got the NASM to install, I must have made an error first time around.
I was happy to see I was able to do it with Terminal in WHM
I'm waiting for this to finish running and then I need to figure out how much garbage I have left and tidy it up. I had got the libvo-aacenc installed it wouldn't configure.
I just added the --enable-version3 \ to the default instructions
Code:
cd ffmpeg
PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="$HOME/ffmpeg_build" \
  --pkg-config-flags="--static" \
  --extra-cflags="-I$HOME/ffmpeg_build/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
  --extra-libs=-lpthread \
  --extra-libs=-lm \
  --bindir="$HOME/bin" \
  --enable-gpl \
  --enable-version3 \
  --enable-libfdk_aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libvpx \
  --enable-libx264 \
  --enable-libx265 \
  --enable-nonfree
make
make install
hash -d ffmpeg
 
Top