Fixed Clicking "More options..." is unreliable for polls.

Affected version
2.2

Pawn Studios

Active member
"When creating a poll the previously filled values were cleared."

When creating a regular thread from the "quick create", clicking "More options..." allows you to continue creating the thread where you left off. The same cannot be said when creating polls:

Image of poll quick create:

1604802632034.png

Clicking More options... sends me to a blank create poll page.


Steps:

1. Go to test forum https://xenforo.com/community/forums/test-messages.6/
2. Use the quick create bar to start creating a poll and click more options.
3. It will be blank.


The more options is actually really buggy. I started writing an article then clicked more options and then it loaded the poll I previously wrote in quick create which I thought disappeared. Then I deleted that, and tried making a new poll in quick create and when I clicked more options it sent me to article with the message body of the poll, so something's really buggy with that button and things aren't instantly loading in. I was using Firefox at the time.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.2).

Change log:
When clicking "more options", ensure that thread type-related fields don't come from a saved draft
There may be a delay before changes are rolled out to the XenForo Community.
 
Top