1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue cli upgrade with xcache enabled throws an error

Discussion in 'Resolved Bug Reports' started by Hoffi, Jun 27, 2013.

  1. Hoffi

    Hoffi Well-Known Member

    I uploaded all files, running Beta1 with no addon enabled. xCache is activated.

    Now I ran the CLI upgrader and got this error:

    Code:
    php library/XenForo/Install/run-upgrade.php
    
    An exception occurred: xcache_get(): xcache.var_size is either 0 or too small to enable var data caching in Zend/Cache/Backend/Xcache.php on line 95
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'xcache_get(): x...', '/var/vhosts/dem...', 95, Array)
    #1 Zend/Cache/Backend/Xcache.php(95): xcache_get('xfxdemo_data_op...')
    #2 Zend/Cache/Core.php(303): Zend_Cache_Backend_Xcache->load('xfxdemo_data_op...', false)
    #3 XenForo/Model/DataRegistry.php(28): Zend_Cache_Core->load('data_options')
    #4 XenForo/Application.php(626): XenForo_Model_DataRegistry->get('options')
    #5 [internal function]: XenForo_Application->loadOptions()
    #6 XenForo/Application.php(818): call_user_func_array(Array, Array)
    #7 XenForo/Application.php(849): XenForo_Application->lazyLoad('options', NULL)
    #8 XenForo/Install/run-upgrade.php(37): XenForo_Application::get('options')
    #9 {main}
    
    I'll wait for further instructions, before I try the standard way, if you need some more stuff.
     
  2. Moshe1010

    Moshe1010 Well-Known Member

    What is your xcache.var_size in your XCache configuration?
    I'm running XCache and I've upgraded with no issues.

    Try removing XCache from config.php, but overall it looks like you need to make xcache.var_size bigger in XCache configuration (mainly php.ini). It depends on the amount of RAM you have and the size of your board.
     
  3. Hoffi

    Hoffi Well-Known Member

    Oh, my xCache Size is 64M. That schould be enough.

    Or not?

    I want to help to prevent this, inside the script.
     
  4. Moshe1010

    Moshe1010 Well-Known Member

    It looks like the upgrade is hungry, so if you have enough RAM try 128M, although it makes little to no sense for if this is the board in your signature.
    Or, try to delete XCache from config.php in your XF installation, upgrade, and then bring it back.
    If you have a GUI panel for XCache, go and look how much RAM it takes and adjust it.
     
  5. Hoffi

    Hoffi Well-Known Member

    Oh, it is the Forum in the right of my sig, and it really makes sense. ;)

    I know, what I can do. I will raise the amount to half a GB. There is enough RAM free on the Server. I think at the weekend I'll give it a try.

    Maybe it is possible to check for the Tool, if there is enough space to prevent an error.
     
  6. Mike

    Mike XenForo Developer Staff Member

    I think this is a server issue - you've got xcache configured in your config.php, but php.ini configuration isn't running via the command line (or it's loading a different php.ini) so different underlying elements are being loaded.

    There's really not much we can do about this and disabling your cache via CLI isn't a good option unless you ensure that you purge it as otherwise there's a potential that stale data is served. You just need to make sure that the same xcache configuration is loaded (you probably want the same php.ini).

    http://stackoverflow.com/questions/3057110/where-can-i-find-the-php-ini-for-php-cli
     
  7. dbembibre

    dbembibre Active Member

  8. dbembibre

    dbembibre Active Member

    I change from xCache to APC and now work from CLI. You need to activate the param apc.enable_cli=1
     

Share This Page