• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Changing node icon

#1
Hello =D I wish to change the node icons, it is my first time so I need some guidance - but I have one problem

In Style Properties>Node Icons>Node Icon - I reset the code and now the background is white. I didn't make a back up of the code unfortunately.

But I wish to change it to a different node icon.

How would I do that?
 
Last edited:

Brogan

XenForo moderator
Staff member
#2
Upload the images to the server.
Update the image path in the SPs for Node Icon: Forum and Node Icon: Unread Forum.
 
#3
Upload the images to the server.
Update the image path in the SPs for Node Icon: Forum and Node Icon: Unread Forum.
Hello @Brogan - I uploaded it into styles>default>xenforo and put this image path:
styles/default/xenforo/charm.jpg

But for "Legion recruit" and "Other Off topic chats" there's no node icon?
 
Last edited:

Martok

Well-known member
#4
But for "Legion recruit" and "Other Off topic chats" there's no node icon?
There are several others missing too.

Inspecting the CSS, you seem to have this set for unread icons:

Code:
background-repeat: no-repeat;
If it is set to this (presumably in the SPs):

Code:
background-repeat: repeat;
Then the icons show.

BTW it's really worth getting to grips with the browser console as this will generally tell you what the issue is. This is how I found the problem just by inspecting an icon that appeared with one that didn't.

You should also look at resizing those icons as they are too big, which is why they are the size they are and cropped.