1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Changing hosts - No pages but home will load

Discussion in 'XenForo Questions and Support' started by Adam K M, Jun 1, 2013.

  1. Adam K M

    Adam K M Active Member

    Hello, I have recently changed hosts for my forums, and have upgraded to 1.1.5 - However, now for some reason, no pages except for the admin control panel, and the actual homepage itself seem to be working...
    I am getting the following error


    404 Not Found

    The server can not find the requested page:
    199.192.230.148/~shortcut/forums/forum/ (port 80)
    Please forward this error screen to 199.192.230.148's WebMaster.

    My old forums are still "up", since this is a test installation (I have however closed the old forums to only being viewable by admins)

    Any help is greatly appreciated...
    What I did during the transfer was transfer over all the files & MySQL DB, then update the install/admin.php file with the new MySQL credentials, then this happens... note that the users in admin controlpanel are working just fine, and everything seems normal in the control panel as well... doing the file health check just told me that everything seemed to be correct.... Maybe it's the .htaccess that I moved over? hmm :s
     
  2. MattW

    MattW Well-Known Member

    Do you have friendly URLs enabled? Is mod_rewrite installed on the new server?
     
    Adam K M likes this.
  3. Adam K M

    Adam K M Active Member


    I believe so, the .htaccess looks like such:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /forums
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Any ideas - maybe they need to be rebuilt somewhere, but how??? (it's still not working)
     
  4. MattW

    MattW Well-Known Member

    Is the module enabled in Apache?

    If you can get to the ACP, try disabling friendly URLs to see if the site starts to load again.
     
    Adam K M likes this.
  5. Adam K M

    Adam K M Active Member

    That fixed it, however I would like to use friendly URLs... How would I go about doing so/sorting out this issue?
     
  6. MattW

    MattW Well-Known Member

    Is this a VPS / Dedicated server? Are you using a control panel on your new server?
     
    Adam K M likes this.
  7. Adam K M

    Adam K M Active Member

    I am using cPanel- webhosting by some company called mineocity
    (So I'm guessing VPS)
     
  8. MattW

    MattW Well-Known Member

    OK, unless you have root access / WHM access to the server, you will need to get the host to enable mod_rewrite for you.
     
  9. The Forum Heroes

    The Forum Heroes Well-Known Member

    the /~ doesn't work with re-write with cPanel outside of the index.php You'll need to wait for for domain to propergate to use friendly url's.
     
    MattW likes this.
  10. MattW

    MattW Well-Known Member

    I didn't realise that, as I've always had that option disabled in WHM
     
  11. Mike

    Mike XenForo Developer Staff Member

    I suspect that's where RewriteBase is needed (as Apache won't resolve the path correctly in that setup).
     

Share This Page