• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cgi:error when I switch from php56 to php70

AndyB

Well-known member
#1
Currently in cPanel I have ea_php56 selected and my forum runs perfectly. But when I switch to ea_php70 attachments are broken. The error_log shows many of these cgi:error messages:

Code:
[Wed Jan 18 01:47:11.242038 2017] [cgi:error] [pid 6275] [client 50.156.102.222:50093] AH01215:   thrown in Unknown on line 0: /usr/local/cpanel/cgi-sys/ea-php70, referer: http://www.southbayriders.com/forums/threads/154530/
What should I check?

Thank you.
 
Last edited:

AndyB

Well-known member
#2
Also I got a bunch of Server Error Logs in the Admin Control Panel like this:

Code:
Error Info
ErrorException: Unknown: Detected an illegal character in input string - Unknown:0
Generated By: hsimpson, Today at 5:55 PM
Stack Trace

#0 [internal function]: XenForo_Application::handlePhpError(8, 'Unknown: Detect...', 'Unknown', 0, NULL)
#1 {main}

Request State

array(3) {
  ["url"] => string(56) "http://www.southbayriders.com/forums/attachments/506441/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

audiokid

Active member
#3
Sounds related to what happened when I upgraded to php 7.0. I had to reinstall ImageMagick PECL Extension again.. http://pecl.php.net/package/imagick
and it took some goofing around to finally click into place. I have no idea why it became an issue because it was installed, working fine in the past php version.

NOTE: php 7.0 works great but 7.1 is problematic. I wasted a whole night on it and finally shifted back to php 7.0.
Avoid php 7.1

Hope some of what I mentioned helps.
 
Last edited:

AndyB

Well-known member
#7
I just checked, iconv is installed on both php56 and php70 and just to be sure I checked with this PHP:

PHP:
<?php

if (function_exists('iconv'))
{
	echo 'iconv exists';	
}
 

AndyB

Well-known member
#15
Also I just checked on my test forum running XenForo 1.5.11 which is on the same dedicated server, when I switch to php70 the same exact problem, attached images will not display.
 

MattW

Well-known member
#17
php 7.0 or php 7.1?

I cannot get 7.1 to work properly.
I'm working on @Anthony Parsons server at the minute, and he has PHP7.1 working fine with cPanel. I also run PHP7.1 on my own server.

Code:
[root@mattwservices ~]# php -v
PHP 7.1.0 (cli) (built: Dec  3 2016 08:42:14) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.1.0-dev, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.1.0, Copyright (c) 1999-2016, by Zend Technologies
 

audiokid

Active member
#18
Update, maybe this helps you too, Andy.
I finally have 7.1 running. I found a pile of 7.1 extensions in the customize provisions that weren't installed. I have no idea if I needed all the extension checked, but I did and it is running great now.
If someone could chime in and share what not to install.... please do :)
I'm hoping I didn't go overboard with all the extensions. PS, I used WHM (cpanel) and it looked for conflicts.
 

audiokid

Active member
#20
Here is what I have in 7.1 now.

PHP 7.1
build

libc-client

libc-client-devel

libc-client-static

pear

php-bcmath

php-bz2

php-calendar

php-cli

php-common

php-curl

php-dba

php-dbg

php-devel

php-enchant

php-exif

php-fileinfo

php-fpm

php-ftp

php-gd

php-gettext

php-gmp

php-iconv

php-imap

php-intl

php-ldap

php-litespeed

php-mbstring

php-mcrypt

php-mysqlnd

php-odbc

php-opcache

php-pdo

php-pgsql

php-posix

php-process

php-pspell

php-snmp

php-soap

php-sockets

php-tidy

php-xml

php-xmlrpc

php-zip

runtime

Others
apr

apr-util

cpanel-tools

documentroot

libmcrypt

modsec-sdbm-util

php-cli

php-cli-lsphp

profiles-cpanel