• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

CentOS Server Management Help

Jeremy

Well-known member
#1
Hey,

My load average is quite high, causing my site hosted on a vPS to run quite slowly. I have complete SSH access (root), can anyone tell me who to figure out why, and restart / reset it?

Here are the load averages:
22.76, 13.47, 11.93

Jeremy
 

John

Well-known member
#4
I don't see anything out of the ordinary in that except for sql. What are you running, db wise, on your server?
 

Jeremy

Well-known member
#9
For yesterday, we got roughly 2,000 hits over the 24 hour period (highest, but we average about 1400-2000 daily). I'm assuming its still high, having issues logging into SSH and plesk to find load... and let's see what it is.... 29.18, 25.62, 19.59 (that's what it is now)
 

Jeremy

Well-known member
#10
Actually, it might be a host issue. There was a system incident with them on a server that I am on.

And... it just took my site down completely. *sigh* Only this week would this happen.
 

Lucas

Well-known member
#11
Yes, that's definitely not normal. No host should go over 2.5 for each core of the server for longer than a minute, in my opinion. Just contact them to see if there is an ongoing issue, otherwise I'd check who is or what is making all those requests to load Apache that high.
 
#12
From TOP it looks like apache is running using prefork MPM. I would suggest switching to (php-fpm + worker-mpm) plus replacing default old mysql version with Percona one (all data and settings will be preserved, just need to remove/install things). Also disable the following Apache modules in /etc/httpd/conf/httpd.conf if you don't specifically need them:

auth_digest_module, authn_alias_module, authn_anon_module, authn_dbm_module, authn_default_module, authz_owner_module, authz_dbm_module, authz_default_module, ldap_module, authnz_ldap_module, deflate_module, usertrack_module, dav_module, autoindex_module, info_module, dav_fs_module, vhost_alias_module, speling_module, userdir_module, proxy_module, proxy_balancer_module, proxy_ftp_module, proxy_http_module, proxy_connect_module, cache_module, suexec_module, disk_cache_module, file_cache_module, mem_cache_module

Don't forget to test your config before restarting Apache with service httpd configtest
 

Blandt

Well-known member
#14
So long it's a managed hosting it's gotta use crapache :D
Get yourself a new host ;) and install nginx .. worth the learning curve
 

Jeremy

Well-known member
#17
You have 18 processes running in that screenshot, and only 33 sleeping, no wonder your load is high. Looks to me like you have only 1GB of memory, and no swap file. Thats a very odd set-up and quite possibly part of your issue.
512 MB actually. But the load has gone down to a reasonable level lately. But the set up is a base MT (dv) server -- I have done no set up once-so-ever.
 

Paul M

Well-known member
#18
512 mb ? Dont see how that can be. The display says 916144 k.

With no swap file the server is going to struggle to work when it gets busy, and either grind to a halt, or just crash.