1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant upload images

Discussion in 'Media Gallery Support' started by Robert O'Connor, Jan 25, 2015.

  1. Robert O'Connor

    Robert O'Connor New Member

    when i try upload an image, i choose the category and then select create an album and nothing happens. nothing pops up for me to create an album.

    i thought it was my php version so i updated it to 5.4. and it still doesn't let me create an album and upload an image.

    i checked all the user permissions and they are all correct as well.

    I'm using the latest xenforo and gallery versions

    here is a link to the site http://www.animetitans.com/xengallery/add

    I'm sure its something simple. thanks
     
  2. Amaury

    Amaury Well-Known Member

    Have you tried disabling all add-ons and using a default style?
     
  3. Mike

    Mike XenForo Developer Staff Member

    Can you upload attachments to threads?
     
  4. Robert O'Connor

    Robert O'Connor New Member

    Just tried it and it still doesn't work
     
  5. Mike

    Mike XenForo Developer Staff Member

    Just to confirm, please attempt to upload a small txt/non-image file as an attachment. If that still doesn't work...

    That implies that there are incorrect file permissions in data/ and internal_data/. I assume that something changed on your server (or your changed servers) as XenForo wouldn't let you install/upgrade without some degree of this being checked.

    Use your FTP client to change the permissions (chmod) the data/ and internal_data/ directories to 0777 (read/write/execute for all). This must be done recursively. Does that solve the problem?
     
  6. Robert O'Connor

    Robert O'Connor New Member

    i could upload an attachment to a post http://www.animetitans.com/threads/sdafbg.3/. but did recently upgrade from shared hosting to vps (diddnt try to upload photos to media before i updated hosting so I'm not sure if it was working before hand)
     
  7. Robert O'Connor

    Robert O'Connor New Member

    the permissions had write disabled. so ill change that but before it do does recursively mean to check the box of 'recurse into subdirectories' (all files and directories)
     
  8. Mike

    Mike XenForo Developer Staff Member

    Well if the attachments work (with an email as well), then it's not likely to be that issue -- I made that response based on you responding after me saying it doesn't work, but that may not have been in response to me.

    But actually, re-reading what you reporting, it's not an uploading an image issue is it? It's an issue with the JS. It certainly appears to me that the Media Gallery JS hasn't been uploaded, so please reupload the Media Gallery files to ensure the JS is uploaded.
     
    Chris D and Robert O'Connor like this.
  9. Robert O'Connor

    Robert O'Connor New Member

    yea i was thinking the same thing. the problem is that when i click create an album nothing happens. ill re upload the js file
     
  10. Robert O'Connor

    Robert O'Connor New Member

    Well Mike.... Your a genius! there must have been some sort of connection issue when i first uploaded the gallery files. It works perfectly now. thanks very much :)
     

Share This Page