1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Can't upgrade !

Discussion in 'Resolved Bug Reports' started by YusufKetur69, Jul 10, 2013.

  1. YusufKetur69

    YusufKetur69 Member

    Hi,

    I have a big problem, i want upgrade 1.1.5 to 1.2 but when I install i have a message error:


    Server Error

    set_time_limit() has been disabled for security reasons

    XenForo_Application::handlePhpError()
    set_time_limit() in XenForo/Deferred/Abstract.php at line 9
    XenForo_Deferred_Abstract->__construct() in XenForo/Deferred/Abstract.php at line 26
    XenForo_Deferred_Abstract::create() in XenForo/Model/Deferred.php at line 59
    XenForo_Model_Deferred->defer() in XenForo/Application.php at line 1213
    XenForo_Application::defer() in XenForo/Install/Model/Install.php at line 329
    XenForo_Install_Model_Install->insertDeferredRebuild() in XenForo/Install/Controller/Upgrade.php at line 209
    XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/Install/Controller/Upgrade.php at line 102
    XenForo_Install_Controller_Upgrade->actionRun() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in Install/index.php at line 18

    Please help
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    You need to enable set_time_limit().
     
    SneakyDave likes this.
  3. YusufKetur69

    YusufKetur69 Member

    How please?
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    You will need to contact your host, unless you are on an unmanaged VPS/Dedicated server.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Kovifor is correct. That is a default PHP function:

    http://us1.php.net/manual/en/function.set-time-limit.php

    The error means that function has been disabled in your PHP configuration (the disable_functions directive). If you have root access to your server then you need to edit the php.ini file to change this. Otherwise contact your host.
     
  6. Mike

    Mike XenForo Developer Staff Member

    The previous comments are correct. That said, I have prevented this error.
     
    Jeremy and shenmuee like this.

Share This Page