1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't seem to get to "elasticsearch setup" admin page

Discussion in 'Enhanced Search Support' started by kontrabass, Dec 4, 2013.

  1. kontrabass

    kontrabass Well-Known Member

    I've installed ES on our master db server, and confirmed that it's reachable from our web server:
    Code:
    [root@web ~]# curl http://192.168.x.x:9200
    {
      "ok" : true,
      "status" : 200,
      "name" : "Valkyrie",
      "version" : {
      "number" : "0.90.7",
      "build_hash" : "36897d07dadcb70886db7f149e8ei83ht83",
      "build_timestamp" : "2013-11-13T12:06:54Z",
      "build_snapshot" : false,
      "lucene_version" : "4.5.1"
      },
      "tagline" : "You Know, for Search"
    }[root@web ~]#
    
    I've entered "192.168.x.x" and port "9200" in the Search Options page, but when I try to go to Tools -> Elasticsearch Setup I get this error:

    Code:
    Error Info
    Zend_Uri_Exception: Invalid URI supplied - library/Zend/Uri/Http.php:156
    Generated By: paul, 6 minutes ago
    Stack Trace
    #0 /home/qwer/html/xenforo/library/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '//http://192.16...')
    #1 /home/qwer/html/xenforo/library/Zend/Http/Client.php(270): Zend_Uri::factory('http://http://1...')
    #2 /home/qwer/html/xenforo/library/Zend/Http/Client.php(253): Zend_Http_Client->setUri('http://http://1...')
    #3 /home/qwer/html/xenforo/library/XenForo/Helper/Http.php(34): Zend_Http_Client->__construct('http://http://1...', Array)
    #4 /home/qwer/html/xenforo/library/XenES/Api.php(35): XenForo_Helper_Http::getClient('http://http://1...', Array)
    #5 /home/qwer/html/xenforo/library/XenES/Api.php(53): XenES_Api->__construct()
    #6 /home/qwer/html/xenforo/library/XenES/ControllerAdmin/Elasticsearch.php(7): XenES_Api::getInstance()
    #7 /home/qwer/html/xenforo/library/XenForo/FrontController.php(337): XenES_ControllerAdmin_Elasticsearch->actionIndex()
    #8 /home/qwer/html/xenforo/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /home/qwer/html/xenforo/admin.php(13): XenForo_FrontController->run()
    #10 {main}
    Request State
    array(3) {
    ["url"] => string(56) "http://www.talkbass.com/xf/admin.php?elasticsearch/"
    ["_GET"] => array(1) {
    ["elasticsearch/"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
    
    I have re-installed Xenforo Enhanced Search to no avail.

    Thanks for any help!:confused:
     
    Last edited: Dec 5, 2013
  2. AndyB

    AndyB Well-Known Member

    This is my Search Options page, perhaps it will help you.

    pic001.jpg
     
  3. AndyB

    AndyB Well-Known Member

    Looks like this line is different in post #1

    Code:
    #4 /home/talkbass/html/xenforo/library/XenES/Api.php(35): XenForo_Helper_Http::getClient('http://http://1...', Array)
    
     
  4. Mike

    Mike XenForo Developer Staff Member

    Based on the error, you actually entered http://192.168.x.x in the server host -- you just want the IP address.
     
  5. kontrabass

    kontrabass Well-Known Member

    Ooops. Adding "http" was a wild guess I tried. Here's the error with just the IP entered:
    Code:
    Zend_Uri_Exception: Invalid URI supplied - library/Zend/Uri/Http.php:156
    Generated By: paul, A moment ago
    Stack Trace
    #0 /home/mysite/html/xenforo/library/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '//192.168.0.18 ...')
    #1 /home/mysite/html/xenforo/library/Zend/Http/Client.php(270): Zend_Uri::factory('http://192.168....')
    #2 /home/mysite/html/xenforo/library/Zend/Http/Client.php(253): Zend_Http_Client->setUri('http://192.168....')
    #3 /home/mysite/html/xenforo/library/XenForo/Helper/Http.php(34): Zend_Http_Client->__construct('http://192.168....', Array)
    #4 /home/mysite/html/xenforo/library/XenES/Api.php(35): XenForo_Helper_Http::getClient('http://192.168....', Array)
    #5 /home/mysite/html/xenforo/library/XenES/Api.php(53): XenES_Api->__construct()
    #6 /home/mysite/html/xenforo/library/XenES/ControllerAdmin/Elasticsearch.php(7): XenES_Api::getInstance()
    #7 /home/mysite/html/xenforo/library/XenForo/FrontController.php(337): XenES_ControllerAdmin_Elasticsearch->actionIndex()
    #8 /home/mysite/html/xenforo/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /home/mysite/html/xenforo/admin.php(13): XenForo_FrontController->run()
    #10 {main}
    Request State
    array(3) {
    ["url"] => string(56) "http://www.mysite.com/xenforo/admin.php?elasticsearch/"
    ["_GET"] => array(1) {
    ["elasticsearch/"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
    
     
  6. kontrabass

    kontrabass Well-Known Member

    UGH. Thanks Mike and Andy for your time. I guess I must have copied/pasted an extra character (space?) into the "host"field. I just went back to the Search Options page and manually typed the IP, and it worked this time.

    Sorry about the dumb error :rolleyes: :D
     

Share This Page