1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Can't post or view profile (Some features don't work)

Discussion in 'Troubleshooting and Problems' started by xmannj2, Jan 14, 2016.

  1. xmannj2

    xmannj2 Member

    I use cloudflare, my databases are hosted with godaddy. Theme is FlatAwesome.

    So recently I've had issues where members cannot post, it shows a blank spot on the screen.

    [​IMG]

    When I try to view profile page it gives me this error:
    Mysqli prepare error: Table 'websitedatabase.xf_widget' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_warning' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_widget' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_warning' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_warning' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_warning' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statement/Mysqli.php:77
    Delete...
    Mysqli prepare error: Table 'websitedatabase.xf_warning' doesn't exist
    Jan 13, 2016 - library/Zend/Db/Statem

    [​IMG]

    Sometimes refreshing the page a few times causes everything to show up on the screen and work.
     
    Last edited: Jan 14, 2016
  2. xmannj2

    xmannj2 Member

  3. Mike

    Mike XenForo Developer Staff Member

    Did you move your site across servers recently? You're missing a table you have no business missing. I'm thinking your database backup/restore wasn't complete, on the basis that it seemed to stop somewhere around the "w" tables.
     
  4. xmannj2

    xmannj2 Member

    Yeah, our host initiated a backup. It's completely fixed now because I added in the missing tables. The other issue was cloudflare.
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Just a wild guess.. but Rocket<exp>Loader?
     
  6. xmannj2

    xmannj2 Member

    Yeah. Rocket Loader doesn't go well with XenForo.
     

Share This Page