1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Can't log into Admin Panel

Discussion in 'XenForo Questions and Support' started by Ben Kember, Nov 13, 2014.

  1. Ben Kember

    Ben Kember New Member

    All of a sudden today, the forum started acting strange. Users started sending me messages that posts weren't showing up and the "New Posts" button was not working although you could refresh the page and then the posts would show up.

    I tried to log into the Admin Panel to see if I could do anything, but when I enter my admin name and password, it accepts it, and then goes right back to the log in screen. No error message, nothing, just a constant log in screen.

    I read some threads speaking about this when people moved servers, but I did nothing today and everything just started freaking out.

    Any help would be appreciated.
    Thank you.
     
  2. Saido

    Saido Member

    Me too, I just installed a clean installation of XenForo Few minutes ago, and I have the same problem :-( Help please
     
  3. Amaury

    Amaury Well-Known Member

    Have you tried disabling all add-ons and seeing if the issues persist?
     
  4. jsmith389

    jsmith389 Member

    I am having these issues also.
     
  5. Saido

    Saido Member

    I found something once you enter the password and username, hit F5
     
  6. Ben Kember

    Ben Kember New Member

    How can I disable my add ons without getting into the admin panel???

    I just tried this but it did not work unfortuatly.
     
  7. Amaury

    Amaury Well-Known Member

  8. cdub

    cdub Well-Known Member

    I'm having same issue starting all of a sudden today. Refreshing the page after you try to log in seems to work.

    What host are you on?
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Several customers are reporting similar problems this evening. All appear to be nginx servers with Hostgator. Please contact Hostgator about this. These are the response headers that I have observed:

    Code:
    Cache-control:max-age=86400
    Connection:keep-alive
    Content-Encoding:gzip
    Content-Length:3770
    Content-Type:text/html; charset=UTF-8
    Date:Thu, 13 Nov 2014 06:54:45 GMT
    Expires:Fri, 14 Nov 2014 06:54:45 GMT
    Last-Modified:Thu, 13 Nov 2014 06:54:45 GMT
    Server:nginx/1.6.2
    Vary:Accept-Encoding
    X-Frame-Options:SAMEORIGIN
    
    This is generated by a PHP resource which should not be cached.
     
  10. Saido

    Saido Member

    I contacted with hostgator, any news here ?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    One customer has suggested it is resolved by adding this to the .htaccess file:

    <IfModule mod_headers.c>
    Header set Cache-Control "no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires 0
    </IfModule>

    Other than that though, this is something Hostgator would have to resolve.
     
    Andrej likes this.
  12. Saido

    Saido Member

    Yes it works, Thank you Brogan
     
  13. cdub

    cdub Well-Known Member

    It still appears to be happening on Hostgator. I'll try modifying that file.
     
  14. cdub

    cdub Well-Known Member

    Yes this definitely works. As usual you are awesome Brogan.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Don't thank me, thank @billytimmy - I believe he was the first one to post the fix.
     
  16. Saido

    Saido Member

    I contacted with hostgator support and they told me this " This was due to a server misconfiguration of caching headers in Nginx, at this we have reverted this configuration and your website should be working as expected. We apologize for any inconvenience this may have caused you. " You should contact with hostgator support.
     
  17. Brogan

    Brogan XenForo Moderator Staff Member

    That's interesting, because they told other customers there was nothing they could do about it.
     
  18. billytimmy

    billytimmy Member

    they are beyond useless over there, they kept wanting to log into the site and see the issue even though I had given them the headers. they dont even support xenforo so I dunno what they were thinking.

    this was second line support too :facepalm:
     
  19. billytimmy

    billytimmy Member

    you guys id'd the problem first, all props to you, I just googled to override it
     
  20. cdub

    cdub Well-Known Member

    Hostgator contacted me to let me know it's fixed.

    Do I know have to undo that changes I did to .htaccess?
     

Share This Page