1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Can't Connect to Twitter upgrading to 1.3.5

Discussion in 'XenForo Questions and Support' started by TheLaw, Aug 17, 2014.

  1. TheLaw

    TheLaw Well-Known Member

    I'm pretty sure it worked before but I can't seem to connect one of my forums to Twitter, despite double checking the information several times. It appears Google+ and Facebook both work without problems trying to verify using "external accounts" as per the instructions. Is there a way to derive a more informative message than the following, which I get trying to login or connect external accounts?

    An unexpected error occurred. Please try again later
     
  2. Mike

    Mike XenForo Developer Staff Member

    Try using the "Test Twitter Integration" system in the control panel. Does it give any details?
     
  3. TheLaw

    TheLaw Well-Known Member

    Thanks Mike - I didn't see the Twitter test, being blinded by the big Facebook Test icon in the center of Tools, lol. So the message I'm receiving is:

    Twitter returned the following error: Could not retrieve a valid Token response from Token URL: Failed to validate oauth signature and token.

    I've got the forum installed in the root directory and have used http :// mysite .com (without the trailing slash) for both Website and callback URL. I've checked the forum and confirmed that this setup worked for others. I've confirmed that the application is set up to accept logins as well. At this point, I'm frustrated thinking I'm probably missing something obvious. :)
     
  4. Mike

    Mike XenForo Developer Staff Member

    First, double check your Twitter key and secret in X to make sure there isn't an issue there.

    Then check your board URL in XF -- does it have the www or is it incorrect?

    Those are really the only thing you have direct control over. There have been some references to this issue being server clock related, but that generally should be ok.
     
  5. TheLaw

    TheLaw Well-Known Member

    No such luck. Checked everything three times. Made sure the server time was set correctly to local time. It is. Rebooted the server, same thing.

    The only changes I can note after reviewing this a dozen times:

    I moved from a dedicated server (where it worked) which was running PHP 5.4 to a VPS which I upgraded to PHP 5.5 because I believe that I saw something here that Twitter can fail using PHP 5.4. I may roll back to 5.4 and see what happens.
     
  6. Mike

    Mike XenForo Developer Staff Member

    There shouldn't be a PHP 5.4-5.5 difference. If you want to submit a ticket with FTP details I can have a look. (I may need to temporarily change the Twitter app associated to a different one as well.)
     
  7. TheLaw

    TheLaw Well-Known Member

    Thanks Mike. Still haven't figured it out but I'll take one more go at it before I request some of your valuable time.
     

Share This Page