Cannot add image to media gallery

megabosx

Active member
#1
I get the following error when i attempt to add an image to the media gallery.

League\Flysystem\FileNotFoundException: File not found at path: 2018/03/224537_84e1e2b0020e62cac2844d21157964bb.jpg in src/vendor/league/flysystem/src/Filesystem.phpat line 385
  1. League\Flysystem\Filesystem->assertPresent() in src/vendor/league/flysystem/src/Filesystem.php at line 193
  2. League\Flysystem\Filesystem->readStream()
  3. call_user_func_array() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 431
  4. League\Flysystem\EventableFilesystem\EventableFilesystem->callFilesystemMethod() insrc/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 395
  5. League\Flysystem\EventableFilesystem\EventableFilesystem->delegateMethodCall() insrc/addons/Xfrocks/AttachmentStore/Fs.php at line 29
  6. Xfrocks\AttachmentStore\Fs->delegateMethodCall() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 154
  7. League\Flysystem\EventableFilesystem\EventableFilesystem->readStream()
  8. call_user_func_array() in src/vendor/league/flysystem/src/MountManager.php at line 269
  9. League\Flysystem\MountManager->invokePluginOnFilesystem() insrc/vendor/league/flysystem/src/MountManager.php at line 179
  10. League\Flysystem\MountManager->__call() in src/XF/Util/File.php at line 91
  11. XF\Util\File::copyAbstractedPathToTempFile() insrc/addons/XFMG/Service/Media/ThumbnailGenerator.php at line 17
  12. XFMG\Service\Media\ThumbnailGenerator->createTempThumbnailFromAttachment() insrc/addons/XFMG/Service/Media/TempCreator.php at line 107
  13. XFMG\Service\Media\TempCreator->_save() in src/XF/Service/ValidateAndSavableTrait.php at line 40
  14. XFMG\Service\Media\TempCreator->save() in src/addons/XFMG/Attachment/Media.php at line 143
  15. XFMG\Attachment\Media->onNewAttachment() in src/XF/Service/Attachment/Preparer.php at line 225
  16. XF\Service\Attachment\Preparer->insertTemporaryAttachment() insrc/XF/Service/Attachment/Preparer.php at line 17
  17. XF\Service\Attachment\Preparer->insertAttachment() in src/XF/Attachment/Manipulator.php at line 170
  18. XF\Attachment\Manipulator->insertAttachmentFromUpload() in src/XF/Pub/Controller/Attachment.phpat line 86
  19. XF\Pub\Controller\Attachment->actionUpload() in src/XF/Mvc/Dispatcher.php at line 249
  20. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 87
  21. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  22. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1889
  23. XF\App->run() in src/XF.php at line 328
  24. XF::runApp() in index.php at line 13
 

Chris D

XenForo developer
Staff member
#2
That file path is not in a familiar format to me. In fact, it looks like there's an add-on involved here, specifically Xfrocks AttachmentStore.

In the first instance you'd need to reproduce the issue with that add-on disabled (so it's only using XF's default file system stuff) or troubleshoot it with the author of that add-on.
 

megabosx

Active member
#3
That file path is not in a familiar format to me. In fact, it looks like there's an add-on involved here, specifically Xfrocks AttachmentStore.

In the first instance you'd need to reproduce the issue with that add-on disabled (so it's only using XF's default file system stuff) or troubleshoot it with the author of that add-on.
Thank you, Let me try and disable the other addon and test
 
Top