• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Can not delete resource prefix from admincp

Affected version
2.0 beta 8
#1
Error: Call to undefined method XFRM\Repository\ResourcePrefix::removePrefixAssociations() src/addons/XFRM/Entity/ResourcePrefix.php:59

#0 src/XF/Mvc/Entity/Entity.php(1471): XFRM\Entity\ResourcePrefix->_postDelete()
#1 src/XF/Admin/Controller/AbstractPrefix.php(136): XF\Mvc\Entity\Entity->delete()
#2 src/XF/Mvc/Dispatcher.php(249): XF\Admin\Controller\AbstractPrefix->actionDelete(Object(XF\Mvc\ParameterBag))
#3 src/XF/Mvc/Dispatcher.php(87): XF\Mvc\Dispatcher->dispatchClass('XFRM:ResourcePr...', 'Delete', 'json', Object(XF\Mvc\ParameterBag), 'xfrmPrefixes', Object(XFRM\Admin\Controller\ResourcePrefix), NULL)
#4 src/XF/Mvc/Dispatcher.php(41): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#5 src/XF/App.php(1845): XF\Mvc\Dispatcher->run()
#6 src/XF.php(328): XF\App->run()
#7 admin.php(13): XF::runApp('XF\\Admin\\App')
#8 {main}
array(4) {

["url"] => string(50) "/admin.php?resource-manager/prefixes/1446.1/delete"
["referrer"] => string(57) "https://site.com/admin.php?resource-manager/prefixes/"
["_GET"] => array(1) {
["resource-manager/prefixes/1446_1/delete"] => string(0) ""
}
["_POST"] => array(4) {
["_xfToken"] => string(8) "********"
["_xfRequestUri"] => string(37) "/admin.php?resource-manager/prefixes/"
["_xfWithData"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 

Mike

XenForo developer
Staff member
#2
This is fixed now, thanks. Looks like it was just calling that method on the wrong object (it got moved a while back).