• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Caching sessions v1.1 beta 5 giving problems!

faeronsayn

Well-known member
#1
Sessions from the Cache

If you have defined a cache in your config file, using memcached, APC, the file cache or any of the other options, XenForo will now store its visitor session data in that cache rather than the database, saving two queries per page. On a busy site, this can be a huge performance boost.

Note that while this feature was in beta 4, to continue using it, you must add this line to library/config.php:
Code:
$config['cache']['cacheSessions'] = true;
Okay, so I tried this, and when ever I enable it, it won't let me get into my admin control panel.

Like I click in login, and it does the animation and then resets and then i click on login again and it does the animation and resets... not sure why...

Thats the only problem I could find. I do have APC enabled.
 

Jake Bunce

XenForo moderator
Staff member
#2

Jake Bunce

XenForo moderator
Staff member
#4
First things first. Have you setup APC caching in your library/config.php file? Or are you just using the opcode cache (no config stuff)?

http://xenforo.com/help/cache/

Or said more directly... does your config file contain this line?

Code:
$config['cache']['backend'] = 'Apc';
Without that line there is no APC cache and therefore no session caching. APC will still improve performance without explicit caching in the config file. But if you want to cache sesssions then you need to explicitly enable APC caching in the config file.

Note that explicit APC caching is only a benefit to busy forums. If you aren't hurting for server resources then this may be more trouble than it's worth (i.e. you should ignore the config file, don't specify any caching in there).
 

faeronsayn

Well-known member
#5
First things first. Have you setup APC caching in your library/config.php file? Or are you just using the opcode cache (no config stuff)?

http://xenforo.com/help/cache/

Or said more directly... does your config file contain this line?

Code:
$config['cache']['backend'] = 'Apc';
Without that line there is no APC cache and therefore no session caching. APC will still improve performance without explicit caching in the config file. But if you want to cache sesssions then you need to explicitly enable APC caching in the config file.

Note that explicit APC caching is only a benefit to busy forums. If you aren't hurting for server resources then this may be more trouble than it's worth (i.e. you should ignore the config file, don't specify any caching in there).
Well my server loads get quite high some times going over 1.0 - 1.5 ... which completely slows down my site...

I've currently took everything unncessary off the config file to solve another problem, once that is solved I am then going to try to enable APC again. Currently I am trying to uninstall it off my server.