1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Cache, simple as adding some lines?

Discussion in 'XenForo Questions and Support' started by SEOmers, Dec 22, 2014.

  1. SEOmers

    SEOmers Active Member

    I've noticed that my site motovlog.com has started to get a bit sluggish at times. The one thing that I haven't done yet is caching.

    Is it really as simple as adding some lines from this? https://xenforo.com/help/cache/

    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';

    How often does the cache reset etc? I don't want people to post then have to wait ages for it to show up?
  2. Mike

    Mike XenForo Developer Staff Member

    There is more to it than that. You have to enable a specific cache backend.

    Provided your cache has enough space to hold the data being cached, you don't really need to worry about managing it. Entries will generally be updated when necessary.
  3. SEOmers

    SEOmers Active Member

    How do i do the backend stuff? I can't have 5-8 second loading. I've had my host look into it, they've suggested the avatar images be cached
  4. HWS

    HWS Well-Known Member

    Most likely you need a more performant server. ;-)
    Images are cached in most browsers automatically. It won't help much if you "cache" them at your server. ;-)
  5. Mike

    Mike XenForo Developer Staff Member

    If you're on a shared server, the cache isn't likely to help you as you won't meet the requirements for a caching system that would provide a benefit (generally Memcached, though single server memory caches can be used if they have been configured correctly; on a shared server you wouldn't have control over this).

    I would echo that it sounds like an overloaded or non-optimally configured server.

Share This Page