• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 cache not created

#1
Here's the config of my forum 1.5. No matter what I try the cache content is not created under configured directory.

<?php
$config['db']['host'] = 'localhost';
$config['db']['port'] = '3306';
$config['db']['username'] = 'root';
$config['db']['password'] = 'root';
$config['db']['dbname'] = 'xenforo';
$config['superAdmins'] = '1';
$config['cache']['cacheSessions'] = true;
$config['cache']['enabled'] = true;
$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions'] = array(
'cache_dir' => '/web/xenforo/data/cache',
// 'cache_dir' => 'data/cache', (This is not working too)
'caching' => true,
'automatic_serialization' => true,
'lifetime' => 0,
'cache_id_prefix' => 'XenForo'
);
//$config['cache']['backend'] = 'WinCache';
$config['cache']['backend'] = 'File';
$config['cache']['cache_dir'] = '/web/xenforo/data/cache';
//$config['cache']['cache_dir'] = 'data/cache'; (This is not working too)
// COOKIES WILL WORK ON ANY SUBDOMAIN OF yoursite.com
$config['cookie'] = array(
'prefix' => 'xf',
'path' => '/',
'domain' => 'local.xenforo'
);

As you could see, I've specified "/web/xenforo/data/cache" as my cache directory. But no content is generated there, it's 777 :(
 

Mike

XenForo developer
Staff member
#2
Your cache_dir needs to be under backendOptions:
Code:
$config['cache']['backendOptions']['cache_dir'] = '/web/xenforo/data/cache';