• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 breadbox shows forum while in homepage

florencia

Active member
#1
Do you know why the breadcrumb in the homepage shows Forum. Also the navigation has Forum highlighted.
I have the homepage to be a page I created different from the forum list.
 

oman

Well-known member
#2
Do you know why the breadcrumb in the homepage shows Forum. Also the navigation has Forum highlighted.
I have the homepage to be a page I created different from the forum list.
It is probably showing that because the page you created was a page node which is part of the node tree or structure.
 

florencia

Active member
#3
ahh and how do you create a node page outside of the tree structure? Because there are no option in the drop-down menu when you create a node for other parent node that is not the root.
The strange thing is that the About doesn't do the same. Its only the home page. I think is more because I have set in the board that the pages/Home/ is my index page and the system has it that the index as a default is the forums, so the template is set in that way. What I do not know is what do I have to change to correct that, because it shouldn't be like that?
 

florencia

Active member
#5
The strange thing is that the About doesn't do the same. Its only the home page. I think is more because I have set in the board that the pages/Home/ is my index page and the system has it that the index as a default is the forums, so the template is set in that way. What I do not know is what do I have to change to correct that, because it shouldn't be like that?
 

florencia

Active member
#11
hello! support support. is there anybody out there? Brogan.... :ROFLMAO::sleep::whistle:
Can someone provide a link to the very simple add-on to remove the forum on the home breadcrumb ?
 

Jeremy

Well-known member
#14
This isn't an error in the software. Pages are a node, and nodes go in the /forum route. As breadcrumbs are hierarchical, forums are included in them.
 

florencia

Active member
#15
But that doesn't happen with the about page for example.


Screen Shot 2014-03-19 at 11.23.00 AM.png

It happens only with the homepage.


Screen Shot 2014-03-19 at 11.22.41 AM.png

So if its works for some pages should also work for the Homepage. Your explanation doesn't fit the rool. The homepage has a bug in the breadcrumb.
 

florencia

Active member
#17
they are both the same. /pages/about/ and /pages/home, but the About page works fine and doesn't have the Forums in the breadcrumb and in the navigation the word About is highlighted to let users know you are in that section. The home being the index page is not working like it should be and like users expected to be. It shouldn't show Forum on the breadcrum and the word Home should be highlighted to show users they are in the Homepage. I think it is a bug in Xenforo and should be fixed.
 

Russ

Well-known member
#18
Are you using the nodes as tabs plugin to achieve the about page in the navigation? If so... I think that add-on adjusts the breadcrumb too if I'm not mistaken.
 

Russ

Well-known member
#20
i'm not sure it is relevant to what its happening with the homepage. The problem is the homepage not the about.
I'm saying... you're trying to say the about page acts differently, and I'm pointing out maybe it's acting differently because you're using a plugin to adjust it, such as nodes as tabs.