• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Brand new install... can't use importer

#1
I have a clean install of xenForo and xenForo Media Gallery. This is on the same server as my PhotoPost install, just one directory over.

I am trying to import for PhotoPost PHP Pro / Gallery.

On the importing page I want to confirm:

MySQL User Name - this is the user name for the PhotoPost DB, correct?
MySQL Database Name - this is the DB name for the PhotoPost DB, correct?

Because I enter all my correct information, as confirmed by cPanel, and I am getting this error:

Error

The source database connection details are not correct: Access denied for user 'bonsainu_photogal'@'localhost' (using password: YES)


[EDIT] This error was created because I was entering "photogal" instead of "photgal" but see the error below [/EDIT]
 
Last edited:

Chris D

XenForo developer
Staff member
#2
This looks like a mistake in the username or password or a connection problem between the databases. The latter seems unlikely if it's hosted locally though.
 
#6
This is exactly what I am entering in the fields (with the exception of my password)

MySQL Server: localhost
MySQL Port: 3306
MySQL User Name: bonsainu_photgal
MySQL Password: [password]
MySQL Database Name: bonsainu_db183921164
Table Prefix: [blank]
Force Character Set: [blank]
Archived Import Log: archived_import_log
vBGallery Files Location: /home/bonsainu/public_html/forums/photopost/data/

I tried entering the password manually, it made no difference.
 
Last edited:
#9
The table prefix is "pp_"

Directly out of the config file: $pp_db_prefix = "pp_";

I enter it manually, and still get the error above.
 
#10
Directly from my PhotoPost config-inc.php

Code:
//**************** MySQL Database Configuration ****************//

// PhotoPost database host address, or leave as localhost
$host="localhost";

// PhotoPost's database name
$database="bonsainu_db183921164";

// MySQL username and password to access PhotoPost's database
//
// These two variables are for the userid and password needed to access
// the PhotoPost database named above.
$mysql_user="bonsainu_photgal";
$mysql_password='[REMOVED]';

// User database host address, or leave as localhost
$host_bb="localhost";

// If you want to use a prefix for your database, enter it here.
// NOTE: This variable can only be set PRIOR to your first installation of PhotoPost;
// existing databases will not be changed and you will be unable to connect if you change
// this variable after performing a default installation.
$pp_db_prefix = "pp_";
 
#12
For what it's worth, I earlier used the xenForo importer to import my vBulletin DB - and had not the slightest problem. So I did not experience a DB connection / permission problem earlier.
 
#16
It's not really a ticket issue - you just need to ensure you are entering the correct database information.

Presumably the database is on the same server as your XenForo installation?

Yes. Both installs are on the same server.

I posted the EXACT values from my config file to show that I am entering the EXACT correct values. I don't know what else to do. I have tried at least 15 times at this point - been stuck here for two hours. I find it interesting that the importer clears me on the first step that the user name can access the database with the password provided... but then tells me it's an incorrect database.

I've checked a billion times to make sure it is the PhotoPost DB and NOT the vBulletin DB.
 

Chris D

XenForo developer
Staff member
#17
If you submit all of your log in details to the open ticket, I'll take a look.

cPanel, and your Admin CP login should suffice. Maybe a fresh set of eyes will help. If not, I'll look at it from a code perspective to see if there's anything going wrong from that end.
 
#19
Thank you both so much. I think I may have figured out at least part of the problem. I was doing an import xenforo < photopost gallery. (Because my product license says PhotoPost PHP Pro / PhotoGallery). When I tried importing xenforo < photopost, I got 95% complete... but then got this error:

Server Error

No such file or directory

  1. Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 459
  2. Zend_Db_Adapter_Abstract->query() in XenGallery/Importer/PhotopostVb.php at line 254
  3. XenGallery_Importer_PhotopostVb->_bootstrap() in XenForo/Importer/Abstract.php at line 107
  4. XenForo_Importer_Abstract->_bootstrapImporter() in XenForo/Importer/Abstract.php at line 86
  5. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 187
  6. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 135
  7. XenForo_ControllerAdmin_Import->actionImport() in XenForo/FrontController.php at line 347
  8. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  9. XenForo_FrontController->run() in /home/bonsainu/public_html/bn2/admin.php at line 13
So frustrating. PART of the photos uploaded and PART of the content is there... until this error popped up.