• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Board title in footer

#1
After upgrading to 1.2.1 the board title in the footer is defaulting to xenforo

Untitled.png

I have not changed my footer title and the board title in options is set correctly to my site... I have tried to change a few options in the footer but no luck...
 

Jon W

Well-known member
#2
It shouldn't be displaying the board title there anyway (see bottom right of this page). Seems very odd.

Check the footer template...
Code:
            <ul class="footerLinks">
            <xen:hook name="footer_links">
                <xen:if is="{$xenOptions.contactUrl.type} === 'default'">
                    <li><a href="{xen:link 'misc/contact'}" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}">{xen:phrase contact_us}</a></li>
                <xen:elseif is="{$xenOptions.contactUrl.type} === 'custom'" />
                    <li><a href="{$xenOptions.contactUrl.custom}" {xen:if {$xenOptions.contactUrl.overlay}, 'class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}"'}>{xen:phrase contact_us}</a></li>
                </xen:if>
                <li><a href="{xen:link help}">{xen:phrase help}</a></li>
                <xen:if is="{$homeLink}"><li><a href="{$homeLink}" class="homeLink">{xen:phrase home}</a></li></xen:if>
                <li><a href="{$requestPaths.requestUri}#navigation" class="topLink">{xen:phrase go_to_top}</a></li>
                <li><a href="{xen:link forums/-/index.rss}" rel="alternate" class="globalFeed" target="_blank"
                    title="{xen:phrase rss_feed_for_x, 'title={$xenOptions.boardTitle}'}">{xen:phrase rss}</a></li>
LOOK SOMEWHERE AROUND HERE!
            </xen:hook>
            </ul>
If you can't see it in that template, then it must be an add-on/template modification. Try disabling add-ons and see if it fixes it.
 
#3
Thanks @Waindigo ... I had found that section and all looked well so could not understand it. I disabled XF's Bigfoot add on and it got rid of the link.

The XF Bigfoot add on does not have anything in its template that looks like it is putting the xenforo title there, but it is definitely responsible for it.
 

Jon W

Well-known member
#4
Ah ok.

In the file library/Bigfoot/Listener.php, remove this bit of code:
PHP:
            case 'footer_links':
            {
                $contents .= '<li><a href="http://xenforo.com/forum">Xenforo</a></li>';
                break;
            }
Unless of course that bit of code is a requirement because of copyright or something like that, in which case you should probably leave it. Perhaps @Mike, @Jake or @Brogan or another staff member can clarify?

Edit: for reference, @jayramfootball is refering to this post.
 
#5
Removing that code throws an error by the way so I think this must be built in my design and not easy to just remove - the link actually goes to an error page at xenforo. I have disabled the add on and deleted it:rolleyes:
 

Jon W

Well-known member
#7
That error sounds like it is to do with whatever editor you used to save the file, rather than the change that I suggested.

The error page on XenForo is because the link is to xenforo.com/forum instead of xenforo.com/community.
 
#8
That error sounds like it is to do with whatever editor you used to save the file, rather than the change that I suggested.

The error page on XenForo is because the link is to xenforo.com/forum instead of xenforo.com/community.

This is the listener.php code after deleting..

Code:
<?phpclass Bigfoot_Listener{  

    public static function templateHook($hookName, &$contents, array $hookParams, XenForo_Template_Abstract $template){      

        switch ($hookName){                      

                case 'footer':{              
                    $contents .= $template->create('bigfoot_bigfoot');              
                    break;  
                }
                      
                                      
        }  
    }
}
Can't spot the error, but I guess there could be some formatting causing it?