1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Add-on BB Code in Poll Responses

Discussion in 'Resource and Add-on Discussions' started by Chris D, Dec 3, 2014.

  1. Chris D

    Chris D XenForo Developer Staff Member

    An add-on was developed by me a couple of years ago for @Dakis.

    It would be mostly up to him whether or not we release it; also there's a chance it may need updating and I can't guarantee when I'll have the time for that.
    egerci likes this.
  2. egerci

    egerci Member

    Thanks I will contact with @Dakis :)
  3. Dakis

    Dakis Well-Known Member

    I am perfectly fine with the release this add on :)
    egerci likes this.
  4. egerci

    egerci Member

    Hello again

    @Chris D, I have contacted with @Dakis and he replied me


    So, Do you think of releasing this add-on?
  5. Chris D

    Chris D XenForo Developer Staff Member

    If Dakis says it's fine (which he has), I'm happy to release it. However, I don't currently know when I'll have the time for that (it will certainly need some level of testing before it's ready).
    Dakis and egerci like this.
  6. egerci

    egerci Member

    It is great. I will waiting for this. Thanks very much.
  7. Chris D

    Chris D XenForo Developer Staff Member

    I tell you what, here it is, attached below.

    @Dakis is 1.5.1 the most recent version you have?

    I just want to add a disclaimer:

    If you install this, it should be fine, but it has not been tested by me personally since this was written over 18 months ago. If you try it, I recommend doing so on a test board and report back any errors. If we consider it to be stable, I'll release it for free in the Resource Manager at some point (with any enhancements needed to bring it up to XF 1.4 speed).

    I'm going to branch some of the posts in the suggestion thread here (https://xenforo.com/community/threads/allow-parsing-of-bb-code-in-poll-responses.46622/) to a new thread better suited to discussion of add-ons.

    (It's also worth noting that this add-on is not affiliated with XenForo Ltd.).

    Attached Files:

    Valhalla and egerci like this.
  8. egerci

    egerci Member

    Hello Again,

    I have tested and find 2 bug
    Fistly when you try to "change your vote" after voting, it will show you unrendered BBCODE and when you vote again it is rendered again and it seems ok. But when you try to change your vote again it broken again.
    And second bug is ; I saw that you changed response field's varchar value to 400 in poll_response table. But text input area's maxlenght is still 100 in the poll editt form. It must be change.
  9. Dakis

    Dakis Well-Known Member

    The latest one I have is 1.5.2 :)
  10. egerci

    egerci Member

    Hello @Dakis ,
    Would you like to attach 1.5.2 to here ? I think @Chris D has no time to consider this. I couldn't use 1.5.1 because of bugs that explained above.
  11. Dakis

    Dakis Well-Known Member

    I'm trying to find it :confused:
    egerci likes this.
  12. Alluidh

    Alluidh Well-Known Member

    Any news?

Share This Page