BB Code Error

DRE

Well-known member
#1
The following error occurred:

preg_match() [function.preg-match]: Compilation failed: two named subpatterns have the same name at offset 309
XenForo_Application::handlePhpError()
preg_match() in XenForo/Helper/Media.php at line 58
XenForo_Helper_Media->_convertMediaLinkToEmbedHtml() in XenForo/Helper/Media.php at line 39
XenForo_Helper_Media::convertMediaLinkToEmbedHtml() in XenForo/BbCode/Formatter/BbCode/AutoLink.php at line 152
XenForo_BbCode_Formatter_BbCode_AutoLink->_autoLinkUrl() in XenForo/BbCode/Formatter/BbCode/AutoLink.php at line 73
XenForo_BbCode_Formatter_BbCode_AutoLink->autoLinkTag()
call_user_func() in XenForo/BbCode/Formatter/Base.php at line 624
XenForo_BbCode_Formatter_Base->renderValidTag() in XenForo/BbCode/Formatter/Base.php at line 539
XenForo_BbCode_Formatter_Base->renderTag() in XenForo/BbCode/Formatter/Base.php at line 463
XenForo_BbCode_Formatter_Base->renderTreeElement() in XenForo/BbCode/Formatter/Base.php at line 444
XenForo_BbCode_Formatter_Base->renderSubTree() in XenForo/BbCode/Formatter/Base.php at line 424
XenForo_BbCode_Formatter_Base->renderTree() in XenForo/BbCode/Parser.php at line 503
XenForo_BbCode_Parser->render() in XenForo/Helper/String.php at line 218
XenForo_Helper_String::autoLinkBbCode() in XenForo/ControllerPublic/Forum.php at line 352
XenForo_ControllerPublic_Forum->actionAddThread() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/mysite/public_html/forum/index.php at line 13
 

DRE

Well-known member
#4
Okay thanks. I see that xenforo's {$id} is the equivalent of vbulletin's {param}

What is xenforo's equivalent for {option}?

For example.

Playlist.com

Code:
<table width="70%" border="0" align="center" cellpadding="2" cellspacing="2"><tr><td><fieldset class="bbfieldset"><legend class="bblegend">{param}</legend>
<div align="center">
<embed style="width:435px; visibility:visible; height:300px;" allowScriptAccess="never" src="http://www.musicplaylist.us/mc/mp3player_new.swf?config=http%3A%2F%2Fwww.indimusic.us%2Fext%2Fpc%2Fconfig_regular_noautostart.xml&mywidth=435&myheight=270&playlist_url=http://www.indimusic.us/loadplaylist.php?{option}" menu="false" quality="high" width="435" height="300" name="mp3player" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" border="0"/>
 
</div>
</fieldset></td></tr></table>
 

Mike

XenForo developer
Staff member
#6
Okay thanks. I see that xenforo's {$id} is the equivalent of vbulletin's {param}

What is xenforo's equivalent for {option}?
That sounds like custom BB code stuff, which we don't support. This is BB code media stuff, and the error was with trying to get the ID from the URL.
 
Top