1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Batch update threads not working

Discussion in 'Resolved Bug Reports' started by Renegade, Aug 6, 2013.

  1. Renegade

    Renegade Well-Known Member

    I tried moving around 20k threads from one forum to another. It goes to the batch update screen and then returns to admin home. Not even a single thread was moved.

    It worked with a smaller batch of 800 threads.
  2. rogerl

    rogerl Member

    I am seeing the same trying to do a bulk delete of threads. Small batches work ok.

    Larger batches don't go to the "processing" screen and just back to admin home with nothing deleted and no server errors reported.

    Running 1.2.0
  3. Mike Fara

    Mike Fara Member

    There is something wrong. I go to Batch Update 37,745 threads to have a thread prefix and it just goes on and on with the refresh... seemingly never ending and even surpassing that number. A quick check shows only about 1,595 threads with that prefix. The process has been running for over 2 hours (or at some point it stopped and continues to show it is updating).
  4. Mike

    Mike XenForo Developer Staff Member

    Note this only comes up if you're updating more than 10,000 threads, but it's a stupid bug.

    library/Model/Thread.php, change:
    $sqlConditions[] = 'thread.thread_id = ' . $db->quote($conditions['thread_id_gt']);
    $sqlConditions[] = 'thread.thread_id > ' . $db->quote($conditions['thread_id_gt']);
    Mike Fara likes this.

Share This Page