XF 2.2 Ban is not showing under Moderator Tools

AndrewSimm

Well-known member
I can't seem to figure out why "Ban" and "Edit Ban" are not showing under "Moderator Tools".

I added "$config['enableListeners'] = false;" to my config to disable listeners to make sure no mods were causing this. I am also not having this issue on my dev server which runs all of my add-ons.

Any thoughts on what I should look at?

Here is what my global permissions look like.
Screen Shot 2021-09-18 at 9.57.43 PM.png
 
Solution
If you have the ban users permission then the option should show.
However, front end stuff is moderator related so ensure the account has moderator status.

The edit ban link will only show for a banned member.

Check in a default style with add-ons disabled.

Brogan

XenForo moderator
Staff member
If you have the ban users permission then the option should show.
However, front end stuff is moderator related so ensure the account has moderator status.

The edit ban link will only show for a banned member.

Check in a default style with add-ons disabled.
 
Solution

AndrewSimm

Well-known member
If you have the ban users permission then the option should show.
However, front end stuff is moderator related so ensure the account has moderator status.

The edit ban link will only show for a banned member.

Check in a default style with add-ons disabled.
Ok, it was because I wasn't a super moderator, just an admin. Though I could still warn, spam clean, and do other things.

Do I need to check permissions under super moderator if the "moderating" usergroup has those permissions? I ask because super moderators of mine don't have access to ban.
 

Brogan

XenForo moderator
Staff member
The account just needs to be promoted to moderator status.

The actual moderator permissions can be set at the user or user group level - the end result is the same.
 
Top