1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Backup xengallery tables => error

Discussion in 'Troubleshooting and Problems' started by rhs, Sep 25, 2015.

  1. rhs

    rhs Member


    i have 2 forums with XF 1.5 and XenGallery. In one forum i have problems with backup the xengallery tables:
    The backup stops after xengallery_media, the next table xengalley_media_view is not backed up and the backup job (created with MySQLDumper) stopped without error msg.

    A repair of this table has not change the situation. The table ist readable and has no errors in XF but even the backup is not ok.

    What can i do?
  2. Mike

    Mike XenForo Developer Staff Member

    There's not really anything that we can do that would allow interference with a backup process. If we could, that's really an issue with the backup tool itself. Thus, you may need to reach out to the MySQLDumper developers.

    You may wish to try just using mysqldump itself for the backup if you're having problems with another tool.
  3. rhs

    rhs Member

    Yes Mike, but the same problem occurs with mysqldump, the backup stopped at table xengallery_media_view ... My question is, what can or should i do with xf to "repair" this table?
  4. Mike

    Mike XenForo Developer Staff Member

    It's a memory table, so there isn't really anything you can do with it. I suppose you could empty the table (though that query is actually run on the table hourly, which should recreate it). What about other memory tables like xf_attachment_view or xf_thread_view?

    I could only guess it's indicative of other server issues if tables are failing to dump.
  5. rhs

    rhs Member

    Thank you, i will try this with empty the memory table. I have no problems with other tables. And, no problems backup other xf-databases on the same server ...
  6. rhs

    rhs Member

    Supplement: i have checked with my provider ... He says he has a "few settings" adapted and today's backup was again completely.

Share This Page