• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Automated Bounced Email Handler- server errors

Sunka

Well-known member
#1
Every half hour I get this error. It is triggered by cron - Process Email Bounces

Code:
Server Error Log
Error Info
Zend_Mail_Protocol_Exception: cannot connect to host; error = (errno = 0 ) - library/Zend/Mail/Protocol/Imap.php:100
Generated By: Unknown Account, 1 minute ago
Stack Trace
#0 /home/nginx/domains/pijanitvor.com/public/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('ssl://imap.gmai...', 993, 'SSL')
#1 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Object(stdClass))
#2 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#3 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999988079071, '')
#4 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999988079071, '', false)
#5 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#6 /home/nginx/domains/pijanitvor.com/public/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}
Request State
array(3) {
  ["url"] => string(39) "https://www.pijanitvor.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(44) "/threads/luk-kozjak-allium-ascalonicum.5870/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
Code:
Server Error Log
Error Info
Zend_Mail_Protocol_Exception: cannot connect to host; error = (errno = 0 ) - library/Zend/Mail/Protocol/Imap.php:100
Generated By: Unknown Account, A moment ago
Stack Trace
#0 /home/nginx/domains/pijanitvor.com/public/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('ssl://imap.gmai...', 993, 'SSL')
#1 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Object(stdClass))
#2 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#3 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9963009357452, '')
#4 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9963009357452, '', false)
#5 /home/nginx/domains/pijanitvor.com/public/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#6 /home/nginx/domains/pijanitvor.com/public/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}
Request State
array(3) {
  ["url"] => string(39) "https://www.pijanitvor.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(98) "/admin.php?cron/emailBounce/run&_xfToken=1%2C1476061415%2C4f2217797ad0b3cb636b5181e33697821e715d64"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
Automated Bounced Email Handler working OK till 26.09.2016.
After that, every half hour I get this error.
Nothing was changed, just stop working.
gmail address for bounced e-mails is same, with same login data and options, amazon ses is same, xenforo acp e-mail settings did not changed...
Where else to look for source of problem?

This is my configuration in ACP

03-15-46.png
 

Brogan

XenForo moderator
Staff member
#2
If you have changed nothing, contact your host and ask them if they have made any changes on the server.

The fundamental issue is this:
Code:
cannot connect to host
Which is a server level issue (assuming the credentials are still valid).
 

Sunka

Well-known member
#3
I managing server. Nothing is changed, and credentials are still valid.
Nothing changed on server, nor with credentials
 

Tracy Perry

Well-known member
#6
If you are running your own server, you should have some error logs you can review.
Only time I've seen that is if the imap server is not running or not listening on the correct port or the ports are blocked for outbound if imap is on a remote server.
And I noticed it appears to be a connection to gmail - so they could also have had something on their end.