• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Partial fix autolink stopped working for a specific website after recent patch

#1
This probably isn't a bug, but I am reporting it anyway. :) Just in case.

I believe it was after the 1.5.10 patch in August that autolink stopped working for this site.

When "Convert URLs to Page Titles" is checked,
Links to this site get renamed "Solicitud Rechazada", which means "request rejected"
http://dle.rae.es/?id=OlQ6yC8

They probably see it as a bot connecting to their servers, instead of a human (which is true).

Confirmed in a XF demo account.

Cheers!
 

Mike

XenForo developer
Staff member
#2
I've made a tweak here. Using a more specific user agent allows the request and is probably a better form, though they're within their rights to limit automated requests if they prefer (and they can still block them without issue). As such, I'm not really sure I should call this "fixed" though the specific issue here may not happen for a period of time. The other half would really be a service issue.
 
#4
I've made a tweak here. Using a more specific user agent allows the request and is probably a better form, though they're within their rights to limit automated requests if they prefer (and they can still block them without issue). As such, I'm not really sure I should call this "fixed" though the specific issue here may not happen for a period of time. The other half would really be a service issue.
Could this be why Facebook links are now auto-linking in chinese (Requires secure authentication)?

Screen Shot 2016-11-03 at 10.02.15 PM.png

Is there a way to turn this feature off for specific domains? Helper/Http.php?
 

Mike

XenForo developer
Staff member
#5
The changes may have indirectly caused that, but it's difficult to say specifically. There's no option that would allow you to adjust this on a per site basis. That would require custom development.