• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Auto-Link titles with Snapshot Preview [Paid] [Deleted]

Rigel Kentaurus

Well-known member
#1
Rigel Kentaurus submitted a new resource:

Auto-Link titles with Snapshot Preview - Enhance your linking situation!

Supercharge the links in your forum, by auto-linking the title. This add-on will fetch the title from the external page, and modify the post to use that.

In addition to that, if configured, you can also generate a screenshot for a snapshot preview of the remote site. When the user hovers over the link, the website will be shown. (Try it here: http://xfaddons.com/threads/auto-link-and-snapshot-preview.909/)


Auto-Linking
Instead of using a...
Read more about this resource...
 

Rigel Kentaurus

Well-known member
#2
Rigel Kentaurus updated Auto-Link titles with Snapshot Preview with a new update entry:

Bug Fixes

Bug fixes
  • If the user specified a title for the URL, the title will not be overwritten anymore
  • CSS fixes for Firefox
  • Whenever the text inside the URL is "complex" (other BBCode, an image), the add-on will not add a favicon. This will prevent an IMAGE to have a favicon to the left
  • Added an option in the AdminCP to disable displaying the favicon
  • Hardened the system for invalid URLs. It was still attempting to resolve them, now they...
Read the rest of this update entry...
 

Adam Howard

Well-known member
#3
I currently have 2 add-ons installed that 1) adds the link and 2) adds the preview (though admittedly not as fast loading as yours does).

I'm almost sold on this add-on (because this one does seem to load faster), but I'd ask for 1 small feature request.... I have another add-on that adds the favicon next to the link. If this will do that as well, I'm sold (will fund the favicon within reason, if required).
 

Adam Howard

Well-known member
#8
Error Info
PHP:
ErrorException: file_put_contents(./data/previews/aHR0cDovL3d3dy51cmJhbmRpY3Rpb25hcnkuY29tL2RlZmluZS5waHA/dGVybT1TZWxmaWUmZGVmaWQ9NDE0Mjg0NA==.png): failed to open stream: No such file or directory - library/XfAddOns/LinkEssentials/Preview/Wordpress.php:57
Generated By: Unknown Account, 18 minutes ago
Stack Trace

PHP:
#0 [internal function]: XenForo_Application::handlePhpError(2, 'file_put_conten...', '/www/public_html/...', 57, Array)
#1 /www/public_html/forums/library/XfAddOns/LinkEssentials/Preview/Wordpress.php(57): file_put_contents('./data/previews...', '??????JFIF?????...')
#2 /www/public_html/forums/library/XfAddOns/LinkEssentials/Preview/Preview.php(65): XfAddOns_LinkEssentials_Preview_Wordpress->_saveImageForUrl()
#3 /www/public_html/forums/library/XfAddOns/LinkEssentials/Deferred/Wordpress.php(22): XfAddOns_LinkEssentials_Preview_Preview->saveImageForUrl()
#4 /www/public_html/forums/library/XenForo/Model/Deferred.php(256): XfAddOns_LinkEssentials_Deferred_Wordpress->execute(Array, Array, 7.99999809265, '')
#5 /www/public_html/forums/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.99999809265, '', false)
#6 /www/public_html/forums/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 /www/public_html/forums/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}
Request State

PHP:
array(3) {
  ["url"] => string(52) "http://www.sociallyuncensored.eu/forums/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(74) "/forums/threads/selfie-taker-gets-kicked-in-head-by-train-conductor.18634/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Adam Howard

Well-known member
#9
Also this error as well, but this only happens for guest as it's always listed from 'unknown account'.

Error Info
PHP:
Exception: The previews directory is not valid: ./data/previews - library/XfAddOns/LinkEssentials/Preview/Preview.php:86
Generated By: Unknown Account, Today at 2:53 PM
Stack Trace
PHP:
#0 /forums/library/XfAddOns/LinkEssentials/Preview/Preview.php(49): XfAddOns_LinkEssentials_Preview_Preview->getSnapshotsDirectory()
#1 l/forums/library/XfAddOns/LinkEssentials/Preview/Preview.php(41): XfAddOns_LinkEssentials_Preview_Preview->generateFileNameAndPath()
#2 /forums/library/XfAddOns/LinkEssentials/Deferred/Wordpress.php(21): XfAddOns_LinkEssentials_Preview_Preview->__construct('http://www.soci...', Array)
#3 /forums/library/XenForo/Model/Deferred.php(256): XfAddOns_LinkEssentials_Deferred_Wordpress->execute(Array, Array, 7.44129300117, '')
#4 /forums/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.44129300117, '', false)
#5 /forums/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#6 /forums/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}
Request State
PHP:
array(3) {
  ["url"] => string(7) "http://"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
Again, this only seems to be affecting guest from what I can tell (always under, 'unknown account')
 

Adam Howard

Well-known member
#10
This is an interesting error.... Again, only seems to be affecting guest.


Error Info
PHP:
ErrorException: Undefined index: HTTP_HOST - library/XfAddOns/LinkEssentials/BBCode/Formatter.php:106
Generated By: Unknown Account, Yesterday at 1:16 PM
Stack Trace
PHP:
#0 /public_html/forums/library/XfAddOns/LinkEssentials/BBCode/Formatter.php(106): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/sociall1/...', 106, Array)
#1 /public_html/forums/library/XfAddOns/LinkEssentials/BBCode/Formatter.php(32): XfAddOns_LinkEssentials_BBCode_Formatter->useInterstitial('https://www.you...')
#2 [internal function]: XfAddOns_LinkEssentials_BBCode_Formatter->renderTagUrl(Array, Array, Object(DigitalPointSyntaxHighlighter_BbCode_Formatter_Base))
#3 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(740): call_user_func(Array, Array, Array, Object(DigitalPointSyntaxHighlighter_BbCode_Formatter_Base))
#4 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(647): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
#5 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(560): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
#6 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(541): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
#7 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(988): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
#8 [internal function]: XenForo_BbCode_Formatter_Base->renderTagSize(Array, Array, Object(DigitalPointSyntaxHighlighter_BbCode_Formatter_Base))
#9 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(740): call_user_func(Array, Array, Array, Object(DigitalPointSyntaxHighlighter_BbCode_Formatter_Base))
#10 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(647): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
#11 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(560): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
#12 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(541): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
#13 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(744): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
#14 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(647): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
#15 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(560): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
#16 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(541): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
#17 /public_html/forums/library/XenForo/BbCode/Formatter/Base.php(521): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
#18 /public_html/forums/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
#19 /public_html/forums/library/XenForo/DataWriter/DiscussionMessage/Post.php(72): XenForo_BbCode_Parser->render('[FONT=Verdana][...')
#20 /home/sociall1/public_html/forums/library/XenForo/DataWriter/DiscussionMessage.php(345): XenForo_DataWriter_DiscussionMessage_Post->_checkMessageValidity()
#21 /home/sociall1/public_html/forums/library/XenForo/DataWriter.php(1446): XenForo_DataWriter_DiscussionMessage->_preSave()
#22 /public_html/forums/library/XenForo/DataWriter.php(1385): XenForo_DataWriter->preSave()
#23 /public_html/forums/library/XfAddOns/LinkEssentials/Deferred/UpdatePost.php(46): XenForo_DataWriter->save()
#24 /public_html/forums/library/XenForo/Model/Deferred.php(256): XfAddOns_LinkEssentials_Deferred_UpdatePost->execute(Array, Array, 7.99999809265, '')
#25 /public_html/forums/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.99999809265, '', false)
#26 /public_html/forums/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#27 /public_html/forums/deferred.php(23): XenForo_Model_Deferred->run(false)
#28 {main}
Request State
PHP:
array(3) {
  ["url"] => string(7) "http://"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Rigel Kentaurus

Well-known member
#14
#15
hi i have a question. does this need special requirements as on my site when i hover it. i see loading but nothing show i tried page2image api wordpress and internal also i have error forbiden for that interstitial page
 

Rigel Kentaurus

Well-known member
#16
hi i have a question. does this need special requirements as on my site when i hover it. i see loading but nothing show i tried page2image api wordpress and internal also i have error forbiden for that interstitial page
The Page2Images needs an API key, you need to sign up for their service and provide the REST API key in the config
The internal one requires that you installed locally WKHtmlToImage
 

Rigel Kentaurus

Well-known member
#18