1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Are XenForo forums hard for search engine crawlers?

Discussion in 'XenForo Questions and Support' started by BGL, Jul 13, 2014.

  1. BGL

    BGL Well-Known Member

    I tested one of the "Build a site map" programs, SiteMap Automater, and it took forever to check my small XenForo forum and was reported back all kinds of redirects and way more pages than my site has. I was wondering if the search engine crawlers would have a similar problem looking at the site and coming up with relevant content to reference.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Google doesn't seem to have any issues.

    Quite the opposite in fact.
  3. dawg

    dawg Well-Known Member

    I never use nor care any of it. Google already knows all about your site and you.
  4. BGL

    BGL Well-Known Member

    Using the tools at Googles Webmaster is what got me started looking. When I run Googles Crawl Errors I get "Failed to load data, please try again later." and with Fetch as Google, I get "Temporarily unavailable" or "Partial". Also seems to take a while. Google suggests doing a site map which got had me trying SiteMapAutomator and then that had trouble.

    Google PageSpeedInsights also came back with an 61/100 with lots of stuff to fix.

    I was wondering if Google just powers through the issues that SiteMapAutomator had.

    Any other suggested tools for checking a XenForo forum besides the Google Webmaster stuff?
    Last edited: Jul 13, 2014
  5. dawg

    dawg Well-Known Member

    Yeah i understand. I dont use any of that stuff and Google finds me just fine. I'm not telling anyone what to do here just letting you know.
  6. Alfa1

    Alfa1 Well-Known Member

    xenforo doesn't have any stock sitemaps functionality. I am not sure how well the addon works. I know it doesn't support many other addons. xenforo seems to do well in search engines, and also applies microdata tags, but optimization is always possible.
    Pagespeed is one of many factors in SEO. None the less it should be good. Read more here: http://xenforo.com/community/threads/need-help-with-boosting-google-pagespeed-insights.59350/
  7. BGL

    BGL Well-Known Member

    Interesting, Floren seemed to say a 61/100 is not that bad for dynamically generated sites which I'm assuming applies to XenForo. Thought the LightSpeed said it couldn't read the forum in Mobile view and that's a bit troubling as it is pretty much out of the box XenForo.
  8. EQnoble

    EQnoble Well-Known Member

    Xenforo does absolutely fine with google...I made a post here like 2 months ago and when I search a two word query at google I get

    About 15,400,000 results
    (0.33 seconds)

    with my thread being in 5th position

    If I add one more word to the search (a three letter preposition) things are still very general and widely covered and not completely specific to anything unique that literally another million sites have posted related materials ... and I get the following...

    About 1,370,000 results (0.38 seconds)
    With my thread returning as the first result.

    I would have to personally submit that xf does fine with search engines (google being the only search engine that I
    use or care about).

    Floren is correct... as an example here is the results for a page owned by a 12 billion dollar company...


    Again xenforo out of the box (+ content) does way better and for a price point that is way (insanely) less than what FOX can afford to throw at a piece of software.

Share This Page