1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache mod_status for munin

Discussion in 'Server Configuration and Hosting' started by hellreturn, Sep 22, 2013.

  1. hellreturn

    hellreturn Active Member

    Well I tried to enable mod status but for some reason it's giving me 404 error.

    Code:
    wget http://localhost/server-status
    --2013-09-22 12:35:05--  http://localhost/server-status
    Resolving localhost (localhost)... 127.0.0.1
    Connecting to localhost (localhost)|127.0.0.1|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    Cookie coming from localhost attempted to set domain to localhost
    2013-09-22 12:35:05 ERROR 404: Not Found.
    My status.conf

    Code:
    <IfModule mod_status.c>
    #
    # Allow server status reports generated by mod_status,
    # with the URL of http://servername/server-status
    # Uncomment and change the "192.0.2.0/24" to allow access from other hosts.
    #
    <Location /server-status>
        SetHandler server-status
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1 ::1
    #    Allow from 192.0.2.0/24
    </Location>
    
    # Keep track of extended status information for each request
    ExtendedStatus On
    
    # Determine if mod_status displays the first 63 characters of a request or
    # the last 63, assuming the request itself is greater than 63 chars.
    # Default: Off
    #SeeRequestTail On
    
    
    <IfModule mod_proxy.c>
        # Show Proxy LoadBalancer status in mod_status
        ProxyStatus On
    </IfModule>
    
    
    </IfModule>
    mod status is already enabled:

    a2enmod status
    Module status already enabled

    But for some reason munnin says this:

    Code:
    apache_accesses            | no   | no [apache server-status not found. check if mod_status is enabled]
    apache_processes           | no   | no [apache server-status not found. check if mod_status is enabled]
    apache_volume              | no   | no [apache server-status not found. check if mod_status is enabled]
    Can some one please help in fixing the issue? Using Debian 7.0.
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Try also allowing your server IP address in addition to localhost (unless you are specifically telling the munin module to monitor the localhost).
     
  3. hellreturn

    hellreturn Active Member

    How do I do that? I am still getting same error.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Code:
    <Location /server-status>
        SetHandler server-status
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1 ::1
        Allow from XXX.XXX.XXX.XXX
    #    Allow from 192.0.2.0/24
    </Location>
    
    Where XXX.XXX.XXX.XXX is your server IP.
     

Share This Page