1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Anyone have issues with SSL not showing images?

Discussion in 'XenForo Questions and Support' started by SEOmers, Jan 27, 2015.

  1. SEOmers

    SEOmers Active Member

    I kind of gate crashed someone elses thread so thought I'd do my own as I'm going round in circles.

    I'm having a right headache with Xenforo and using SSL. I brought a certificate from GEOtrust via WHMCS.

    I have installed and the host, pinchhost have confirmed that nothing is wrong with it.

    However, when I change the site to https, also add https: in options>Basic Board Information I get the site loading but but without CSS or most images https://motovlog.com/

    I have covered

    • Changed URL in basic board information
    • Changed htaccess which then causes a loop (dead site)
    • Code:
      RewriteCond %{SERVER_PORT} 80
          RewriteRule ^(.*)$ https://motovlog.com/$1 [R,L]
    • Changed the theme to default to see if that makes any difference at all, it doesn't

      Any suggestions from you guys?
     
  2. SEOmers

    SEOmers Active Member

  3. Solidus

    Solidus Well-Known Member

    From the source code:

    Code:
    http://<base href="http://motovlog.com/" />
    You can redirect properly with this code once you fix this.

    Code:
    RewriteCond %{SERVER_PORT} !^443$
    RewriteCond %{HTTPS}  off
    RewriteRule ^(.*)$ https://motovlog.com/$1 [R=301,L]
     
    SEOmers likes this.
  4. SEOmers

    SEOmers Active Member

    That's the thing. I don't know where that's coming from. As far as I can tell, I've done it right
     

    Attached Files:

  5. SEOmers

    SEOmers Active Member

    Attached Files:

    Last edited: Jan 27, 2015
  6. Mike

    Mike XenForo Developer Staff Member

    You're using CloudFlare. You need to ensure that CloudFlare is contacting your forum using HTTPS.

    What web server is your actual server running?
     
  7. SEOmers

    SEOmers Active Member


    I disabled Cloudflare aka change nameservers back to my host, it shouldn't be using it at all. My host is Linux and I use Cpanel


    I thought I'd test out Cloudflare as I thought it would be easier, it wasn't
     
  8. Mike

    Mike XenForo Developer Staff Member

    Motovlog.com resolves to an IP owned by CloudFlare (OpenDNS appears to have this IP as well) and there's a header indicating CloudFlare in the request. I would double check that you've disabled CloudFlare as you expect.
     
  9. SEOmers

    SEOmers Active Member

    Could have been my error, well is. I've gone into godaddy again and changed back to my original nameservers. Lets see but I think I'll now get a dead https altogether
     
  10. SEOmers

    SEOmers Active Member


    This seems to have hit the spot now the nameservers have gone back to my original host. I'm getting a yellow triangle now, this site doesn't though?>
     
  11. Mike

    Mike XenForo Developer Staff Member

    It appears to be something relating to your logo (images/logo1.jpg). You need to change the URL to that where ever it's defined.
     
    SEOmers likes this.
  12. SEOmers

    SEOmers Active Member

    And boom. I now have https and working properly
     
  13. SEOmers

    SEOmers Active Member

    Thanks to everyone
     
  14. Solidus

    Solidus Well-Known Member

    If you want to switch back to cloudflare, just use full ssl or full ssl strict.
     
    SEOmers likes this.
  15. SEOmers

    SEOmers Active Member

    I think I'll leave it for the moment. It's working now.

    However I'm going to test with another website with them so thanks for the tip
     

Share This Page