1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Animated Avatars

Discussion in 'Troubleshooting and Problems' started by TeflonDon, Jun 9, 2013.

  1. TeflonDon

    TeflonDon Well-Known Member

    I enabled imagick so I could upload animated avatars and it doesn't seem to be working correctly. I uploaded a gif as my avatar and now its displaying like this

    upload_2013-6-9_16-1-19.png

    upload_2013-6-9_16-1-31.png


    Here is my phpinfo.

    upload_2013-6-9_16-2-9.png

    Did I do something wrong?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Jake Bunce and TeflonDon like this.
  3. TeflonDon

    TeflonDon Well-Known Member

  4. TeflonDon

    TeflonDon Well-Known Member

  5. stilly

    stilly Active Member

    I had the same problem, I had to:

    Open template message_user_info

    Find
    Code:
    <xen:avatar user="$user" size="m" />
    Replace with
    Code:
    <a class="username avatar Av{$user.user_id}l" href="{xen:link members, $user}">
    <img src="{xen:helper avatar, $user, l, 'true'}" alt="{$user.username}" style="max-height:96px;max-width:96px;" itemprop="photo" />
    </a>

    As per this thread http://xenforo.com/community/threads/animated-avatars-in-threads.14807/
     
  6. TeflonDon

    TeflonDon Well-Known Member

    I applied that change but unfortunately it didn't change anything, my avatar is still static in the postbit.


    edit: Disregard, for some reason I can't select the ImageMagick PECL Extension option in the admin panel anymore so something might be wrong with my installation.
     
    Last edited: Jun 10, 2013
  7. stilly

    stilly Active Member

    Not sure what to tell you then, my member_info_user info looks like this and it works:

    Code:
    <xen:require css="message_user_info.css" />
    
    <div class="messageUserInfo" itemscope="itemscope" itemtype="http://data-vocabulary.org/Person">	
    <div class="messageUserBlock">
    	<xen:hook name="message_user_info_avatar" params="{xen:array 'user={$user}', 'isQuickReply={$isQuickReply}'}">
    		<div class="avatarHolder">
    			<span class="helper"></span>
    			<a class="username avatar Av{$user.user_id}l" href="{xen:link members, $user}">
    <img src="{xen:helper avatar, $user, l, 'true'}" alt="{$user.username}" style="max-height:96px;max-width:96px;" itemprop="photo" />
    </a>
    			<!-- slot: message_user_info_avatar -->
    I have left out everything below <!-- slot: message_user_info_avatar -->

    Dont use the first bit in the thread for guest..
     
  8. TeflonDon

    TeflonDon Well-Known Member

    Thanks. I'm going to try a fresh install of 3.1.0RC2 and see if that works. I think there was a problem with my last install.
     
  9. TeflonDon

    TeflonDon Well-Known Member

    Apparently 3.0.1 is the latest stable version and running a beta version apparently causes conflicts.

    Now I'm back to having my images broken. :confused: Not sure what else I can try...
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Running just fine on Debian Wheezy.
    phpinfo().png
     
    Adam Howard likes this.
  11. TeflonDon

    TeflonDon Well-Known Member

    I installed the latest beta version and my uploaded avatars still display broken.

    upload_2013-6-12_2-35-4.png



    upload_2013-6-12_2-36-8.png
     
  12. Tracy Perry

    Tracy Perry Well-Known Member

    You are still running 6.5.4-7 of ImageMagick. If you notice, mine is on 6.7.7-10, so you are still behind on that. You have two things to install, the Imagemagick pecl to install and and then the library. Have you updated both?
    What OS are you running?
    Edit: doing a little research indicates if you are on centOS, then you are on the latest shipping version. Have you added the remi repository and seen if they have a newer version?
    http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x
     
    Last edited: Jun 12, 2013
  13. TeflonDon

    TeflonDon Well-Known Member

    I haven't done any of that. This is starting to get a little beyond me. I'm not really sure what to do next. Is there any documentation I can look at to get a better idea of what I need to install?

    Thanks
     
  14. Tracy Perry

    Tracy Perry Well-Known Member

    Again, are you running centOS? The link I gave you shows how to add the RHEL EPEL to your repository.
     
  15. TeflonDon

    TeflonDon Well-Known Member

    CENTOS 6.4 x86_64
     
  16. Tracy Perry

    Tracy Perry Well-Known Member

    TeflonDon likes this.
  17. Tracy Perry

    Tracy Perry Well-Known Member

  18. TeflonDon

    TeflonDon Well-Known Member

    Thanks for your help but I'm going to have to wait for a more user friendly way of doing this to come along.
     
  19. Tracy Perry

    Tracy Perry Well-Known Member

    If you are running your own VPS or dedicated server (unmanaged) then there isn't any more "user friendly" way than this - unless it's hiring someone to administer your system or finding someone who will do it for free. If it's a managed system, then you should simply be able to submit a request - but with it being "non-standard" they may not do it.
     
    TeflonDon likes this.
  20. TeflonDon

    TeflonDon Well-Known Member

    At some point the things you're asking me to update will be gold releases instead of beta and these upgrades will be automatic. I'll either wait for that or for XF to figure out an alternative.

    I have managed hosting but I prefer to have a bit more knowledge of the things I'm asking them to do. I don't like to experiment with things I'm not experienced with, especially on a live server. Thanks for the help, I may reference this thread in the future if I get some free time to research everything you've suggested.
     

Share This Page