• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Animated avatars in thread view.

andrewkm

Active member
#1
When clicking on users profile, you can see the animated .gif avatar should they have one.
However in thread view, there is no animation. Is there a way to enable the animation everywhere?
 

OUTL4W

Active member
#2
acp>option>attachments>
scroll down to "Default Image Processor" and chooses "ImageMagick PECL Extension"...if you can't chooses it then you need pcel extension installed on server.
 

andrewkm

Active member
#3
acp>option>attachments>
scroll down to "Default Image Processor" and chooses "ImageMagick PECL Extension"...if you can't chooses it then you need pcel extension installed on server.
My options show:


Seems blurred out, not sure if installed?
It's animating in the profile but not thread view.
 

Paul

Well-known member
#4
I have the same issue. Any animated Gif that was uploaded a while ago works fine - Anything new that has been uploaded doesn't animate in threadview..

Interestingly i note that whilst my display shows the same as above, If i change to PHP built in, I cannot change back to Imagemagick PECL extension afterwards.
 

Jeremy P

Well-known member
#5
My guess would be that imagick used to be installed but got removed, possibly during an upgrade. It's greyed out/disabled if XF can't detect its presence.
 
Last edited:

Paul

Well-known member
#6
Yup - i agree :) I seem to remember I asked my hosts to upgrade PHP about 6 months ago - i suspect they upgraded and didnt include the extension - Therefore meaning that anything uploaded prior to 6 months ago works fine, however anything newer that has been uploaded cannot be resized by imagemagick, and therefore gets displayed as a static image...