• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Anchor and Go To BBCode (SMF Style) 1.0

No permission to download
#1
Iomega0318 submitted a new resource:

Anchor and Go To BBCode (SMF Style) - Anchor and Go To BBCode (SMF Style)

I was looking for a way to add in anchors like SMF uses, and reading on the forums the solutions I found just would not work and I didn't feel like installing a mod to handle it, so I fixed it myself.

This uses the SMF style of BBCodes, [IURL] & [ANCHOR]
This is an export of both BBCodes directly from the BB Code & Smilies section of the Xenforo Admin, so that is where you will import the XML.

Don't wish to import it?

Add it in yourself using the following:
(You can of course rename...
Read more about this resource...
 

DRE

Well-known member
#2
Not sure most noobs would know know what this is for. Can you explain what anchors are users are used for in the resource?
 
#3
Not sure most noobs would know know what this is for. Can you explain what anchors are users are used for in the resource?
Of course lol, this allows you to create a hyperlink using the [IURL] tag linking to for example "#Bottom" so the link in this case would read:
http://xenforo.com/community/threads/anchor-and-go-to-bbcode-smf-style.71938/#Bottom

You then somewhere else on the page, or in another post for example use the [ANCHOR] tag to define "Bottom". This does nothing by itself except tell the link you created with the first tag where to go.

When you click the link it will take you to the anchor on the same page without reloading.

This works similar to when you view a specific post here, for example when you link your post above it shows:
http://xenforo.com/community/threads/anchor-and-go-to-bbcode-smf-style.71938/#post-748745
The "#post-748745" is essentially your anchor in this case and the link is the iurl tag when you click that link it loads the page and takes you to the post.

You can read more about it here:
http://help.typepad.com/anchor-tags.html
and demo it here:
http://www.UOFreeshards.net/index.php?topic=221.0
(Still currently running my SMF board but it works the same. May or may not work, my host kind of sucks atm. If it loads for you the first post is where all the [IURL] tags are and the additional posts use the [ANCHOR] tags.)
 
#5
Entered the two BB codes verbatim. Doesn't work. Nothing happens which you click the links.
They need to be used like so:
Code:
USE:
[iurl=NAME]NAME[/iurl]
Code:
USE:
[Anchor=NAME]NAME[/Anchor]
The IURL goes first then the ANCHOR tags, THEY MUST ALSO MATCH and must either be in the same post or at least on the same page this will not work from one page to another.
If the post you send the IURL to is on page 2 of the thread for example it will not work.

You can test it below:
http://www.UOFreeshards.com/threads/smf-iurl-anchor-bbcode-test-for-xenforo.280/

**EDIT**
Just checked, this does not seem to work in FF or Chrome, I will have to look into why. But this does work on IE.
(You can see it working in IE by following this link: https://browserling.com/queue?uri=h...for-xenforo.280/&browser=explorer&version=9.0)
 
Last edited:

Slind

Active member
#7
They need to be used like so:
Code:
USE:
[iurl=NAME]NAME[/iurl]
Code:
USE:
[Anchor=NAME]NAME[/Anchor]
The IURL goes first then the ANCHOR tags, THEY MUST ALSO MATCH and must either be in the same post or at least on the same page this will not work from one page to another.
If the post you send the IURL to is on page 2 of the thread for example it will not work.

You can test it below:
http://www.UOFreeshards.com/threads/smf-iurl-anchor-bbcode-test-for-xenforo.280/

**EDIT**
Just checked, this does not seem to work in FF or Chrome, I will have to look into why. But this does work on IE.
(You can see it working in IE by following this link: https://browserling.com/queue?uri=http://uofreeshards.impson.me/threads/smf-iurl-anchor-bbcode-test-for-xenforo.280/&browser=explorer&version=9.0)
Doesn't work with Opera :/
https://browserling.com/queue?uri=h...-xenforo.280/#NAME&browser=opera&version=20.0
 
#9
I haven't been on in a while but for some reason I could never find a fix to work in anything but IE, I have tried a lot and it would fail every time. So for now this is only for IE but I will continue to look for a solution since it bugs me.

On the bright side thanks to the 1.4 release you can now have empty Anchor tags!
 

NinaMcI

Active member
#10
Hi,
I've just purchased the Resource Manager and have been trying for the last couple of hours to create a BB Code anchor/go to link for a glossary resource: A-Z letters across the top linking to the relevant letter in the resource. I've tried following the illustration on here, but just cannot make it work.
Please, please could someone explain how to do this?
Thanks