[Already Exists] Disable signature viewing

compwhizii

Active member
Can the users get an option to disable signatures? I really hate having to scroll past loads of crap, and 5 lines of text after a 2 word reply look silly.
 

Brogan

XenForo moderator
Staff member
You can set default registration settings in the ACP -> Users and Registration: Default Registration Values

If you want to disable signatures completely then configure it in the usergroup permissions: Edit signature - set it to Default.
 

mrb1972

Active member
ok, I may be wrong but I assume this will only effect new users on new boards

I have imported a number of users from VB4, who had sigs in their profile and show up on xenforo, I dont want sigs to show at all but they still do even with the above settings in xenforo?
 

Brogan

XenForo moderator
Staff member
The importer will import signatures regardless so you will need to manually remove them.
You could do this with an SQL query by deleting the contents of xf_user_profile:signature for all members.
 

mrb1972

Active member
ahh ok.. perhaps having a global "disable sigs" option would be handy, or the option not to import sigs.. would be better
 

kforo

Active member
If you want to disable signatures completely then configure it in the usergroup permissions: Edit signature - set it to Default.
Edit signature: -

"not set/no" - is the right one? Seems like "Never" would be blocking the use of signatures, no?
 

Brogan

XenForo moderator
Staff member
Never will block it for all members who are in that user group.

Not Set (No) will block it for all members, unless they are members of another user group which has it set to Allow.

So you can override Not Set (No) using Allow, but you can't override Never.

http://xenforo.com/help/permissions/
 

TazDevilLooney

Active member
The importer will import signatures regardless so you will need to manually remove them.
You could do this with an SQL query by deleting the contents of xf_user_profile:signature for all members.
What would the SQL query be to remove all signatures?
 

Brogan

XenForo moderator
Staff member
I suspect you used " instead of '' (2 separate ').

If you copy and paste the line in my post above it will work fine.
 
Top