Resource icon

[AL] Core Package 1.2.3

No permission to download

AddonsLab

Well-known member
AddonsLab submitted a new resource:

[AL] Core Package - Shared library files used by all AddonsLab add-ons

The package contains libraries we share between several our add-ons. Until now the files were included in packages of the add-ons themselves, however, having multiple add-ons to using the same files can sometimes cause a conflict between them, if they are using different versions of the files.

The package does not implement any visible functionality itself, it is just a collection of PHP classes reused by multiple add-ons. You don't need to install it if you are not using any of our add-ons.

Read more about this resource...
 

AddonsLab

Well-known member
Is there a list of add-ons that require this update?

Usually the update is required for a specific add-on, which is released the same time as this package and would not be possible to install or upgrade without having this version of the core package. If this package contains a recommended for all customers, that will be mentioned in the release notes.

It is completely safe to upgrade this package anytime, as the changes will always be backwards-compatible.

Thank you!
 

Sunka

Well-known member
Do we need this addon installed if we only have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge?
 

AddonsLab

Well-known member
Do we need this addon installed if we only have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge?

Every add-on that requires a particular version of the Core package can't be installed without it, so if you have already installed any of the add-ons, that means you have an appropriate version of the Core package and you don't need to upgrade it.

Future versions of add-ons may require a new version of [AL] Core package and will need to upgrade it before installing them.

Thank you!
 

Sunka

Well-known member
I have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge but also I have installed two of your addons and uninstalled them few days ago (guest posting and link checker).
So now I only have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge and [AL] Core Package addon,
Could I uninstall now [AL] Core Package addon or not (and leave installed Unread post count and navigation Badge)?
 

AddonsLab

Well-known member
I have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge but also I have installed two of your addons and uninstalled them few days ago (guest posting and link checker).
So now I only have installed [AddonsLab] Unread Post Count and [AddonsLab] navigation Badge and [AL] Core Package addon,
Could I uninstall now [AL] Core Package addon or not (and leave installed Unread post count and navigation Badge)?

Yes, you can uninstall the Core package, it is not needed for any of these add-ons.

If you want to delete all associated files, please use the ZIP package and delete the content from the server matching the structure of the ZIP.

Thank you!
 

Firestrm_ZA

Member
Tried updating AL-Threadfilter but get blocked by:

Could not process AL-ThreadFilter-3.4.0.zip: The following requirements for [AddonsLab] Thread Filter were not met: [AddonsLab] Thread Filter requires [AL] Core Package 1.1.3+.

When will 1.1.3 be available? @AddonsLab?
 
Top