1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 After import, attachments all showing as thumbnails

Discussion in 'Installation, Upgrade, and Import Support' started by Amin Sabet, Feb 18, 2015.

  1. Amin Sabet

    Amin Sabet Well-Known Member

    I imported photography forums from vBulletin to Xenforo. After the import. attachments which were previously displayed full size inline are now showing as thumbnails.

    Example: http://www.mu-43.com/index.php?threads/flowers.2696/page-193#post-740565

    Is there any way for me to fix this and have all the attachments show full size without re-doing the import?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I suspect they are using the basic attach code, rather than attach=full.
    You have attachment viewing disabled for guests so only the thumbnails show anyway.

    You could do a find and replace on [ATTACH] and replace with [ATTACH=full] in the post table.
    You can do that as a query or using the post content replace add-on.

    Take a backup of the database first before running any queries.
     
  3. Amin Sabet

    Amin Sabet Well-Known Member

    Would this work in phpMyAdmin:

    Code:
    UPDATE`xf_post`SET`field_name`= replace(same_field_name,'[ATTACH]','[ATTACH=full]')
    
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Code:
    UPDATE xf_post SET message = REPLACE(message,'[ATTACH]','[ATTACH=full]');
    Take a backup first, just in case.
     
    RoldanLT and dougdirac like this.
  5. Amin Sabet

    Amin Sabet Well-Known Member

    Thanks very much, Brogan. Do I need to shut down my site before running that operation?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You shouldn't need to but you can always close the forum in the ACP.
     
  7. Amin Sabet

    Amin Sabet Well-Known Member

    Worked perfectly. Thanks again, Brogan.
     
    Last edited: Feb 18, 2015

Share This Page