1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

admindav.php/WebDAV Throwing Apache Error

Discussion in 'Troubleshooting and Problems' started by Distortion, Mar 11, 2011.

  1. Distortion

    Distortion Member

    I've spent the best part of today trying to get XenForo's feature of WebDAV integration working but with no success. To get right to the point these are the relevant access/error logs:

    This is fairly strange as I know WebDAV is working, I setup a test directory and it worked fine:
    Code:
    <Directory "C:\Program Files\Zend\Apache2/htdocs/uploads">
        Dav On
        Order Allow,Deny
        Allow from all
        AllowOverride All
        AuthType Digest
        AuthName DAV-upload
        AuthUserFile "C:\Program Files\Zend\Apache2/user.passwd"
        AuthDigestProvider file
        <LimitExcept OPTIONS>
        require user admin
        </LimitExcept>
    </Directory>
    I can connect and use this WebDAV instance without issue using a normal mapped network drive in windows or 3rd party applications like NetDrive.

    Other Info:

    - Windows Home Server
    - Fresh install of Zend Server CE
    - No .htaccess with authentification assigned to the XenForo installation
    - Attempted the Zend Server CE "patch" that has worked for some within .htaccess/httpd.conf with no luck ( RewriteRule ^admindav.php - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},NC,L] )
    - No log is being generated within ./xenforo/internal_data/

    Here's my config for the root of my server incase it'll help:
    Code:
    <Directory "C:\Program Files\Zend\Apache2/htdocs">
     Dav On
     Options Indexes FollowSymLinks
     Order allow,deny
     Allow from all
     AllowOverride All
    
     <IfModule mod_rewrite.c>
      RewriteEngine On
      # If you are having problems with the rewrite rules, remove the "#" from the
      # line that begins "RewriteBase" below. You will also have to change the path
      # of the rewrite to reflect the path to your XenForo installation.
      RewriteBase /xenforo
      RewriteRule ^admindav.php - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},NC,L]
      RewriteCond %{REQUEST_FILENAME} -f [OR]
      RewriteCond %{REQUEST_FILENAME} -l [OR]
      RewriteCond %{REQUEST_FILENAME} -d
      RewriteRule ^.*$ - [NC,L]
      RewriteRule ^(data|js|styles|install) - [NC,L]
      RewriteRule ^.*$ index.php [NC,L]
     </IfModule>
    </Directory>
    I've done by best to search online for any kind of meaning to the related apache errors but nothing has worked, so I'm hoping someone has an idea as to where I'm going wrong (or what's going wrong). Let me know if you need any further information :)
     
  2. Mike

    Mike XenForo Developer Staff Member

    I don't believe you need "Dav On" - as a matter of fact, that likely conflicts by firing up mod_dav instead. That would likely fit with it returning a 400 (bad request) error.
     
  3. Distortion

    Distortion Member

    Thanks Mike - That stopped the error but the http authentification just kept cycling which is a bit odd. As mentioned above I tried the rewrite rule to patch that issue but had no success, since this is a local install I changed $authValid to true within admindav.php and that has fixed the issue :)
     
  4. Luke F

    Luke F Well-Known Member

    You can't have two sets of HTTP authentication - has to be either the one in Apache or the one in XenForo.
     
  5. Distortion

    Distortion Member

    There is no authentification within my apache setup, and the one in XenForo wasn't working so my admindav.php as it stands is completely unprotected (but it's for local purposes).
     
  6. Luke F

    Luke F Well-Known Member

    My bad, was looking at the first block of code in the OP
     
    Distortion likes this.
  7. Distortion

    Distortion Member

    No problem at all, appreciate the assistance :)
     

Share This Page