1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Admin Filter doesn't update when text cleared

Discussion in 'Resolved Bug Reports' started by SheepCow, Jan 21, 2011.

  1. SheepCow

    SheepCow Well-Known Member


    The filters on the admin control panel don't seem to update when you delete the text in the filter using the web browsers built in "x" button inside the text box.


    Screen shot 2011-01-21 at 21.15.26.png

    When looking at the phrases, if you type "create" it updates the list with all the phrases that match:

    Screen shot 2011-01-21 at 21.15.40.png

    If you then delete the text "create" (by pressing the "x" inside the text box (a feature of <input type="search">):

    Screen shot 2011-01-21 at 21.15.49.png

    It doesn't put all the phrases back (but it has cleared the text):

    Screen shot 2011-01-21 at 21.15.52.png

    Browser is Chrome 9.0.597.67 on Mac OS X, same happens in Safari 5.0.3.
  2. Trombones13

    Trombones13 Well-Known Member

    I think the X just deletes your text so you can type something new, and the Clear button is what you really want.
  3. SheepCow

    SheepCow Well-Known Member

    Well I think it'd be better if it was consistent with what happens when you delete the text manually and press the clear button
  4. Trombones13

    Trombones13 Well-Known Member

    Yeah; perhaps that could be revisited.
  5. MYstIC G

    MYstIC G Active Member

    SheepCow... I know this name... ;)
  6. Green Cat

    Green Cat Active Member

    Isn't the x a feature of webkit ? I am pretty sure they can either keep the way it works not or get rid of it, I don't this they can do much else.
  7. SheepCow

    SheepCow Well-Known Member

    The x is part of whatever browser you're using (edit: although I think it's only WebKit that does it atm), the HTML5 JS "search" event should let you catch it
    Mike likes this.
  8. Mike

    Mike XenForo Developer Staff Member

    Indeed the search event does catch it, so fixed now. :)

Share This Page